Results 1 to 2 of 2
  1. #1

    cgi not working on CPanel??

    i have an account, the cgi doesn't work? it was working fine when the account was first set up, but then always! after a period of time, cgi stops working. while cgi still working in other accounts.
    how do i find out where went wrong?

    it has happened to several of my accounts, what i did was terminate the account, and setup again. then it works again

    the cgi scripts are fine. coz they work fine in other accounts on the same server with the same config.

    i did "perl test.cgi". it's working fine. but when i use browser to access the cgi, it's showing 500 Internal Server error".

    I enabled SuExec, and hit "Fix insecure permissions on cgi scripts. (requires suexec)"... but still showing the error...

    I also tried the program in other account on the same server, it's working well... no matter using a browser to access... or in shell..

    please help!!
    Last edited by torwill; 08-22-2002 at 11:27 AM.

  2. #2
    Join Date
    Jul 2002
    Try manually chmodding the files in the cgi bin to 755. The fix permissions thing in cpanel is dodgy. It's never worked properly as far as I can tell.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts