Results 1 to 4 of 4
  1. #1
    Join Date
    Aug 2005
    Posts
    529

    weird spamd issue

    hey guys,

    i have this really annoying issue i'm hoping you can help with.

    it seems the spamd child process gets stuck and causes 100% cpu usage. but this doens't just happen randomly, its only for this single user account. e.g. take a look at top output:

    4581 <username> 93 40:58.87 1.3 82624 52m 2280 R spamd child

    the 93 is 93% cpu usage. 40:58 is how long the process has been running, 40 minutes and counting (i just killed it though). and all it tells me its running spamd child. it usually dies after a few hours but only after causing 200% cpu usage (100% on both cpus) and making my server load skyrocket. This happens at least twice daily at no set times.

    this user isn't a spammer. no scripts, no mail queue generation, no email accounts even.

    any ideas?

    running cpanel 11, centos 4.

  2. #2
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    Could be the incoming mails
    Sam
    Supportlobby.com - Expertise in Windows/Linux server support, IaaS and PaaS Management
    Spiralbean.com - Custom Software Development
    Email: exec @ activelobby.net | Skype: unni_active

  3. #3
    Join Date
    Aug 2005
    Posts
    529
    thought of that. there are no email accounts, all unrouted goes to :blackhole:, and i've even changed the domain's MX entries to 10.10.10.10 just so nobody can even connect to me for this domain's mail!

  4. #4
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    Quote Originally Posted by chamelion View Post
    thought of that. there are no email accounts, all unrouted goes to :blackhole:, and i've even changed the domain's MX entries to 10.10.10.10 just so nobody can even connect to me for this domain's mail!

    Wierd. Did u confirm the number of mails currently in the queue ?
    Sam
    Supportlobby.com - Expertise in Windows/Linux server support, IaaS and PaaS Management
    Spiralbean.com - Custom Software Development
    Email: exec @ activelobby.net | Skype: unni_active

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •