Results 1 to 12 of 12

Thread: Glibc

  1. #1
    Join Date
    Dec 2006
    Posts
    288

    Glibc

    I have a RHEL4 Box and need to upgrade glibc. Currently have glibc-2.3.4-2.39 installed. I have downloaded glibc-2.7-2.i386.rpm and tried to install with

    #rpm -Uv glibc-2.7-2.i386.rpm

    but received the following error:
    Code:
     
    error: Failed dependencies:
            glibc-common = 2.7-2 is needed by glibc-2.7-2.i386
            glibc > 2.3.4 conflicts with glibc-common-2.3.4-2.39.i386
            glibc = 2.3.4-2.39 is needed by (installed) glibc-headers-2.3.4-2.39.i386
            glibc = 2.3.4-2.39 is needed by (installed) glibc-devel-2.3.4-2.39.i386
    Any suggestions?

  2. #2
    Join Date
    Apr 2003
    Location
    San Jose, CA.
    Posts
    1,622
    download a newer/newest rpm for glibc-common, glibc-headers, and glibc-devel
    and install them all together.
    Daved @ Lightwave Networking, LLC.
    AS1426 https:/www.lightwave.net
    Primary Bandwidth: EGIHosting (NLayer, NTT, HE, Cogent)
    Xen PV VPS Hosting

  3. #3
    Join Date
    Dec 2006
    Posts
    288
    Thanks! I have downloaded all of the RPM's. Would I install the glibc-common, glibc-headers, and glibc-devel before glibc? Or would I install all 4 at the same time? Also, is this the command to install them at the same time:

    #rpm -Uh glibc-common-2.7-2.i386.rpm glibc-headers-2.7-2.i386.rpm glibc-devel-2.7-2.i386.rpm

    Thanks!
    Last edited by smrtalex; 04-21-2008 at 10:58 AM.

  4. #4
    Join Date
    Dec 2006
    Posts
    288
    Here is what I received:
    #rpm -Uh glibc-2.7-2.i386.rpm glibc-common-2.7-2.i386.rpm glibc-headers-2.7-2.i386.rpm glibc-devel-2.7-2.i386.rpm

    Code:
     
    warning: glibc-2.7-2.i386.rpm: V3 DSA signature: NOKEY, key ID 4f2a6fd2
    error: Failed dependencies:
    binutils < 2.15.94.0.2-1 conflicts with glibc-devel-2.7-2.i386

  5. #5
    Join Date
    Sep 2002
    Location
    Top Secret
    Posts
    11,686
    I think you're making things a bit more complicated than they should be really. Is there a reason you can't use up2date?

    Code:
    up2date glibc
    This will resolve dependencies, download the necessary files and go from there.

    If it's saying that things are 'up to date', don't touch it! Don't change a thing, because redhat does it's own setups, manages it's own updates, and if you change, even the smallest of things, you can break an entire box quickly.
    WHMCS Guru - WHMCS addons, management, support and more.
    WHMCS Notifications Extended - Add slack, hipchat, SMS, pushover to WHMCS !!
    Always looking for Linux, WHMCS, Support Desk work. PM for details

  6. #6
    Join Date
    Oct 2003
    Location
    Orlando, FL
    Posts
    244
    Be very careful when reinstalling glibc. If possible upgrade in a safe environment. If this is your first time I suggest using a server management company or your hosting company to do the upgrade.
    Paul

  7. #7
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    Unless you know exactly what you are doing...

    STOP NOW..

    Why is it you want to upgrade your glibc? What do you require from a newer one?

    Glibc is tied into basically every binary on the machine, and if you install some incompatible rpms you run the risk of breaking the machine.
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  8. #8
    Join Date
    Dec 2006
    Posts
    288
    Trying to install php 5.2.5. When I compile from source it errors with
    Code:
    configure: error: The PCRE extension requires PCRE library version >= 6.6
    So I get the pcre rpm = pcre-7.3-1.i386.rpm
    #rpm -Uh pcre-7.3-1.i386.rpm pcre-devel-7.3-1.i386.rpm
    and it errors with:
    Code:
     
    error: Failed dependencies:
    libc.so.6(GLIBC_2.4) is needed by pcre-7.3-1.i386
    rtld(GNU_HASH) is needed by pcre-7.3-1.i386
    Currently this is what is installed for glibc:
    glibc-2.3.4-2.39
    glibc-kernheaders-2.4-9.1.100.EL
    glibc-headers-2.3.4-2.39
    vzdummy-glibc-1.0-1.swsoft
    glibc-common-2.3.4-2.39
    glibc-devel-2.3.4-2.39

    How do I get libc.so.6?

  9. #9
    Join Date
    Sep 2002
    Location
    Top Secret
    Posts
    11,686
    smrtalex:
    you might want to check out this thread which should help you a bit. This has happened before. Basically, you need to download the source PCRE files and compile them, then tell php where you compiled things into. That thread should help you getting pcre going though.
    WHMCS Guru - WHMCS addons, management, support and more.
    WHMCS Notifications Extended - Add slack, hipchat, SMS, pushover to WHMCS !!
    Always looking for Linux, WHMCS, Support Desk work. PM for details

  10. #10
    Join Date
    Dec 2006
    Posts
    288
    Thanks, that helped. I was able to compile php 5.2.5, make and make install. But when I run php-v I get a bunch of errors like:
    Code:
     
    PHP Warning: PHP Startup: bcmath: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    And php is not running and test pages, I put up. Any suggestions?

  11. #11
    Join Date
    Sep 2002
    Location
    Top Secret
    Posts
    11,686
    Quote Originally Posted by smrtalex View Post
    Any suggestions?
    Get yourself a systems administrator before you majorly screw up your system
    WHMCS Guru - WHMCS addons, management, support and more.
    WHMCS Notifications Extended - Add slack, hipchat, SMS, pushover to WHMCS !!
    Always looking for Linux, WHMCS, Support Desk work. PM for details

  12. #12
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    Quote Originally Posted by smrtalex View Post
    Thanks, that helped. I was able to compile php 5.2.5, make and make install. But when I run php-v I get a bunch of errors like:
    Code:
     
    PHP Warning: PHP Startup: bcmath: Unable to initialize module
    Module compiled with module API=20050922, debug=0, thread-safety=0
    PHP compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    And php is not running and test pages, I put up. Any suggestions?

    that happened because you are still trying to load the old modules due to your previous php setup.
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •