Results 1 to 1 of 1
  1. #1
    Join Date
    Apr 2008
    Location
    Arganda, Madrid, Spain
    Posts
    67

    poedit translation

    Hello guys
    This thing is driving me crazy!
    I am trying to use the poedit to translate a php hello world website. Although it seems to me that I am doing everything alright, I still don't see the translation in my browser when I browse
    http://localhost/pruebalocal1/caca/test.php

    The only thing I see is the original message, that is to say, "Hello World". I have done the translation with poedit though. Moreover, I saved it in two files called messages.po and messages.mo

    This is my test.php code:

    <?php
    $locale = "de_DE";
    putenv("LC_ALL=$locale");
    setlocale(LC_ALL, $locale);
    bindtextdomain("messages", "./locale");
    textdomain("messages");
    print "<p>".gettext("Hello World")."</p>\n";
    ?>


    My poedit screen looks like the screenshoot attached.

    My directories are like this:

    C:\xampp\htdocs\pruebalocal1\caca
    C:\xampp\htdocs\pruebalocal1\caca\test.php
    C:\xampp\htdocs\pruebalocal1\caca\locale
    C:\xampp\htdocs\pruebalocal1\caca\locale\de_DE
    C:\xampp\htdocs\pruebalocal1\caca\locale\de_DE\LC_MESSAGES C:\xampp\htdocs\pruebalocal1\caca\locale\de_DE\LC_MESSAGES\messages.po
    C:\xampp\htdocs\pruebalocal1\caca\locale\de_DE\LC_MESSAGES\messages.mo

    I hope I have explained myself clearly enough.
    Please, I would appreciate any help about this issue.
    Thanks in advance
    Attached Thumbnails Attached Thumbnails screenshot.PNG  

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •