Results 1 to 8 of 8
  1. #1

    cPanel: addon domain creation problem

    I've the following problem:

    domain name has 4 NameServers (dns management hosting). I created A record to point to shared IP (the hosting where I'd like to host web site). When I try to add "addon domain" cPanel keeps telling me that dns is configured wrong and I have to use hosting's NS

    ---
    Error from park wrapper: Using nameservers with the following IPs: 72.20.25.134,66.252.1.255,67.18.179.15,67.19.72.206 Sorry, the domain is already pointed to an IP address that does not appear to use DNS servers associated with this server. Please transfer the domain to this servers nameservers or have your administrator add one of its nameservers to /etc/ips.remotedns and make the proper A entries on that remote nameserver.
    ---

    However, if I create subdomain (at dns management hosting) and point to same shared ip address, cPanel creates addon domain without any doubts...

    I've contacted hoster... but their best solution is to use their NS which i dont wanna do

    any help would be much appriciated.

  2. #2
    Join Date
    Jul 2001
    Location
    .INdiana
    Posts
    2,394
    change to their nameservers. create the addon.
    then change back to your preferred nameservers.
    And if this old world starts a getting you down
    There's room enough for two, up on the roof

  3. #3
    Thanks for reply. I thought of that too... (might do it actually)
    but is not that wierd that another domains work fine with same hosting, i could add as many of other domain is I want... but ONE does not work at any time

  4. #4
    Check if have anything wrong at whm -> tweak settings -> Domains section.

  5. #5
    Quote Originally Posted by CD Burnt View Post
    change to their nameservers. create the addon.
    then change back to your preferred nameservers.
    I think it's the only way when cpanel check dns of park/addon domains
    Some hosts may disable this checking but it's default recommended setting in cpanel.
    PremiumReseller.com Hyper-V SSD VPS USA London Singapore
    Reseller Hosting Cpanel PURE SSD CloudLinux Softaculous
    Windows Reseller Asp.NET 4.5 MSSQL 2012 SmarterMail Enterprise

  6. #6
    Join Date
    Sep 2002
    Location
    Among the corn
    Posts
    10,648
    Because the nameservers aren't pointing to the server's nameservers (as suggested), it is throwing the error. This is becoming more and more common as individuals start using more and more outsourced dns (dnsmadeeasy, etc).

    How to resolve it? There are two ways:
    #1: change your nameservers to point to the 4 server's nameservers (all of them, not just one or two). This can result in downtime, however, and isn't really recommended.

    #2: Fix the option in WHM. In whm->tweak settings, make sure that this option is checked:
    Allow Creation of Parked/Addon Domains that resolve to other servers (i.e. domain transfers) [This can be a major security problem. If you must have it enabled, be sure to not allow users to park common internet domains.]
    This really is redundant any more and doesn't need to be used. Just make SURE to follow the instructions and NOT allow users to park common domains.

    This can (at times) become a security issue, but only if you don't keep a close eye on what your users are doing.

  7. #7
    How to do that in the new cpanel. I do not have such options!

  8. #8
    Join Date
    Mar 2009
    Location
    Miami, Florida
    Posts
    18,883
    Quote Originally Posted by hardjoko View Post
    How to do that in the new cpanel. I do not have such options!
    Hello,
    This is found in WHM under "Tweak Settings". The option is now called "Allow Remote Domains"
    Keith I Myers
    CEO and Founder - RemoteRAM.com
    The world leader in Cloud Based RAM
    KMyers.me The rantings of a lunatic

  9. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •