Results 1 to 10 of 10
  1. #1

    LFD spamming me !! help 100 email / min

    welcome

    Every menute I recive this letter from LFD :

    lfd: Excessive resource usage: X (27264)

    Time: Tue Apr 15 08:31:27 2008
    Account: X
    Resource: Virtual Memory Size
    Exceeded: 157 > 100 (MB)
    Executable: /usr/bin/php
    Command Line: /usr/bin/php
    PID: 27264
    Killed: No
    Why I Recive this ?
    are there any probs ?
    must I care about it ?
    How I can fix it ?

    Thanks

  2. #2
    Hi,

    This means that the php process LFD is talking about is eating too much memory.

    You should either investigate and see if that process is allowed to run and use so much memory or you can just tell LFD to ignore the php processes(which is not a good idea) by doing the following: WHM -> Plugins -> ConfigServer Security & Firewall -> lfd Process ignore -> add the process name(/usr/bin/php) to the end of the text area, press Change and then restart lfd
    Server Surgeon George
    http://www.serversurgeon.com
    Linux, BSD and Windows Administration Services
    Toll Free US 877-378-7436 International +1-213-291-9191

  3. #3
    Join Date
    Sep 2002
    Location
    Top Secret
    Posts
    11,686
    Actually, you're close.
    In this case, you're looking at php (not LFD) being too much of a hog, and you really shouldn't add php to the 'ignore' list. That's a bad idea in general.


    What you need to do is find the root of this, see if this is caused by client crons, or something else. A php script taking that much memory is bad news and shouldn't be ignored
    WHMCS Guru - WHMCS addons, management, support and more.
    WHMCS Notifications Extended - Add slack, hipchat, SMS, pushover to WHMCS !!
    Always looking for Linux, WHMCS, Support Desk work. PM for details

  4. #4
    linux-tech, that's exactly what I said in my post
    Server Surgeon George
    http://www.serversurgeon.com
    Linux, BSD and Windows Administration Services
    Toll Free US 877-378-7436 International +1-213-291-9191

  5. #5
    Join Date
    Sep 2002
    Location
    Top Secret
    Posts
    11,686
    Actually, you suggested adding php to lfd exclude, which is bad.
    You're right, you said LFD was catching on php, I misread the original response, but still, excluding php is a very bad idea, and defeats the purpose of having LFD to begin with
    WHMCS Guru - WHMCS addons, management, support and more.
    WHMCS Notifications Extended - Add slack, hipchat, SMS, pushover to WHMCS !!
    Always looking for Linux, WHMCS, Support Desk work. PM for details

  6. #6
    If you read closely I said that it is not a good idea to make LFD ignore the php process

    I just told him what are his options(the good one and the bad one)
    Server Surgeon George
    http://www.serversurgeon.com
    Linux, BSD and Windows Administration Services
    Toll Free US 877-378-7436 International +1-213-291-9191

  7. #7
    thanks guys
    I think that was helpfull

    the server have only one account ! the owner use a php script to upload big files ?

    I think in this case it can be ignored

  8. #8
    Join Date
    Sep 2002
    Location
    Top Secret
    Posts
    11,686
    If you've just got one person doing this, I would personally add the user's name to the ignore list, not php itself. This should stop the emails.

    It does make sense though that larger uploads would take up more memory.
    WHMCS Guru - WHMCS addons, management, support and more.
    WHMCS Notifications Extended - Add slack, hipchat, SMS, pushover to WHMCS !!
    Always looking for Linux, WHMCS, Support Desk work. PM for details

  9. #9
    Thanks linux tech

  10. #10
    Join Date
    Oct 2008
    Posts
    313
    Well, lfd is "spamming" me too.
    Is there a way to add a username to the exclude list or a dir? I don't want to add certain process, just certain user (other me).


    edit: It looks like I fixed it myself by adding user:username in the lfd Process Ignore list
    Last edited by xeno007; 10-09-2008 at 05:48 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •