Results 1 to 11 of 11
  1. #1
    Join Date
    Nov 2004
    Posts
    673

    Question How to block all emails from a certain address?

    I am receiving around 7.000 emails from different sources with the subject “Undelivered Mail Returned to Sender” or similar.

    It seems someone is using an alias to my email address to send huge amounts of spam. I have checked the mail queue in WHM and the emails are not there. I have turned on the SMTP Tweak in security center, but that doesn’t seem to work.

    I have no idea if this person is using my server to send massive amounts of spam, or just using my domain as alias to piss me off.

    What I have noticed is that most emails return to [email protected] so is there a way to block this?

  2. #2
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    Add this in the file /etc/antivirus.exim and restart exim.

    Code:
    if error_message and $header_from: contains "[email protected]"
    then
      fail text "Mail rejected"
      finish
    endif
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  3. #3
    Join Date
    Nov 2004
    Posts
    673

  4. #4
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    Add a new line with $header_to also.
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  5. #5
    Join Date
    Nov 2004
    Posts
    673
    Thanks you. Can I do this in WHM or do I need to go to the root command line?

  6. #6
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    You can do this from command line. Take a backup of the file before editing.

    cp /etc/antivirus.exim /etc/antivirus.exim.BKP
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  7. #7
    Join Date
    Nov 2004
    Posts
    673
    Thanks alot

  8. #8
    Join Date
    Nov 2004
    Posts
    673
    Unfortunatly it does not seem to work. When I restarted Exim, I had not returned spam for about 2 mintues, then it all started again

  9. #9

    Thumbs up

    Email bounce spam often results from spammers using a spoofed email address (yours) to send out spam. Although there is not much that can be done about that, spammers often use from email addresses that actually exist. Most likely you have a catch-all email active on your domain meaning that [email protected] is said to be a valid email address by the server. These are perfect fake addresses for spammers to use (since when the recipient tries to verify if the sender is real, your server will say it exists). The first step would therefore be to disable your catch-all (assuming it is enabled). Furthermore a good spam filter that effectively handles bounce spam and uses proper SMTP rejections will also make your domain much less useful as a spoofed sender.
    Leading Webhosting Email Security Solutions, Incoming & Outgoing Filtering + Email Archiving!
    Clusterable, Scalable, in the Cloud or on Premises, Fully Managed, 4-Tier Control, Plugins for all Major Control Panels, and an Extensive API!
    SpamExperts - "The way email was meant to be - Simply SpamFree"
    (www.spamexperts.com)

  10. #10
    Join Date
    Nov 2004
    Posts
    673
    Thank you srenkema for taking time to post your feedback.


    David from cliffsupport loged in and fixed the problem within 15 mintues
    Last edited by Johnburk; 04-17-2008 at 10:06 AM. Reason: spelling mistake

  11. #11
    Ok cool - in any case - you know where to find me now cheers
    Leading Webhosting Email Security Solutions, Incoming & Outgoing Filtering + Email Archiving!
    Clusterable, Scalable, in the Cloud or on Premises, Fully Managed, 4-Tier Control, Plugins for all Major Control Panels, and an Extensive API!
    SpamExperts - "The way email was meant to be - Simply SpamFree"
    (www.spamexperts.com)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •