Results 1 to 22 of 22
  1. #1
    Join Date
    Mar 2008
    Posts
    35

    problem with www.

    ok so i own the site called: http://epicplayer.info

    but when you enter : www.epicplayer.info into your browser the page deosnt come..

    does anyone know why?

  2. #2
    Join Date
    May 2007
    Location
    Chicago
    Posts
    322

  3. #3
    Join Date
    Mar 2008
    Posts
    35
    web server?

    as in my host?

  4. #4
    Join Date
    May 2007
    Location
    Chicago
    Posts
    322

  5. #5
    Join Date
    Jun 2002
    Location
    New York, USA
    Posts
    180
    Quote Originally Posted by gast3 View Post
    ok so i own the site called: http://epicplayer.info

    but when you enter : www.epicplayer.info into your browser the page deosnt come..

    does anyone know why?
    Although it appears an A record exist for both the domain and the www. Your host hasn't configured it to answer correctly to the www. I would contact your host with this question.
    EZHostz.Biz (Established in 2003) a DotJunction.Com Company.
    EZHostz.Biz <-> Reseller Info Domain Name Sales, WebHosting, Email Only Hosting, & Much More.
    Providers of Directi & Enom Reseller Accounts.

  6. #6
    Join Date
    Jan 2008
    Location
    St. John's, NL
    Posts
    2,114
    Definitely a DNS issue. Ask your host to set up a "A record" called "www" and point it to your IP address.
    Cpanel/WHM PHP Perl Ruby Full Time Support
    LCWSoft - Canada web hosting (based in Newfoundland) since 2007
    Servers based in the US and Canada (Uptime Report)

  7. #7
    Join Date
    May 2007
    Location
    Chicago
    Posts
    322
    Quote Originally Posted by larwilliams View Post
    Definitely a DNS issue. Ask your host to set up a "A record" called "www" and point it to your IP address.
    No, it's not DNS:
    [email protected]:~$ host epicplayer.info
    epicplayer.info has address 74.86.136.217
    [email protected]:~$ host www.epicplayer.info
    www.epicplayer.info has address 74.86.136.217
    Apache just isn't configured to respond to the www request.

  8. #8
    Join Date
    Jun 2002
    Location
    New York, USA
    Posts
    180
    Quote Originally Posted by larwilliams View Post
    Definitely a DNS issue. Ask your host to set up a "A record" called "www" and point it to your IP address.
    The A records exist, it's a config problem with the server.
    EZHostz.Biz (Established in 2003) a DotJunction.Com Company.
    EZHostz.Biz <-> Reseller Info Domain Name Sales, WebHosting, Email Only Hosting, & Much More.
    Providers of Directi & Enom Reseller Accounts.

  9. #9
    Join Date
    Mar 2008
    Posts
    35
    ok so bottom line: its a config problem?

  10. #10
    Join Date
    Jan 2006
    Location
    Athens, Greece
    Posts
    1,479
    For your virtual host:

    ServerName www.domain.com
    ServerAlias domain.com *.domain.com

  11. #11
    Join Date
    Jun 2002
    Location
    New York, USA
    Posts
    180
    Quote Originally Posted by gast3 View Post
    ok so bottom line: its a config problem?
    Yes.

    You can check here http://www.hscripts.com/tools/HDNT/dns-record.php

    both epicplayer.info and www.epicplayer.info point to 74.86.136.217 .
    EZHostz.Biz (Established in 2003) a DotJunction.Com Company.
    EZHostz.Biz <-> Reseller Info Domain Name Sales, WebHosting, Email Only Hosting, & Much More.
    Providers of Directi & Enom Reseller Accounts.

  12. #12
    Join Date
    Mar 2008
    Posts
    35
    but then how come www.epicplayer.info doesnt work even though it points to the ip?

  13. #13
    Join Date
    Jun 2005
    Posts
    5,866
    Put this in your .htaccess file in the root directory of the domain..

    RewriteEngine On
    RewriteCond %{HTTP_HOST} .
    RewriteCond %{HTTP_HOST} !^www\.epicplayer\.info [NC]
    RewriteRule (.*) http://www.epicplayer.info/$1 [R=301,L]
    Signature Under Construction.

  14. #14
    If you have cpanel in your hosting you can do the forward through the panel.

  15. #15
    Join Date
    Mar 2008
    Posts
    35
    Quote Originally Posted by stu2 View Post
    Put this in your .htaccess file in the root directory of the domain..

    RewriteEngine On
    RewriteCond %{HTTP_HOST} .
    RewriteCond %{HTTP_HOST} !^www\.epicplayer\.info [NC]
    RewriteRule (.*) http://www.epicplayer.info/$1 [R=301,L]
    is their a special place i should put that above ^^

  16. #16
    Create a file named .htaccess in the root folder and copy paste it in there.
    I didn't check it myself but if I know stu he knows what he's talking about

    The best option though would be to send an email to your webhost and describe the problem, they will create an alias for www in their webserver config.

  17. #17
    Join Date
    Jun 2002
    Location
    New York, USA
    Posts
    180
    Quote Originally Posted by gast3 View Post
    but then how come www.epicplayer.info doesnt work even though it points to the ip?
    Because the IP is pointing to the server, but the server doesn't know how to handle the alias.
    Last edited by ebay-nut; 04-06-2008 at 04:21 PM.
    EZHostz.Biz (Established in 2003) a DotJunction.Com Company.
    EZHostz.Biz <-> Reseller Info Domain Name Sales, WebHosting, Email Only Hosting, & Much More.
    Providers of Directi & Enom Reseller Accounts.

  18. #18
    Join Date
    Jun 2002
    Location
    New York, USA
    Posts
    180
    What stu2 said should work, note the .htaccess is usually a hidden text file @ the root. A simple text editor will get the job done then rewrite the file.

    It's almost amazing though that this isn't done @ the server level for all domains residing on the server.
    EZHostz.Biz (Established in 2003) a DotJunction.Com Company.
    EZHostz.Biz <-> Reseller Info Domain Name Sales, WebHosting, Email Only Hosting, & Much More.
    Providers of Directi & Enom Reseller Accounts.

  19. #19
    Join Date
    Jun 2005
    Posts
    5,866
    Quote Originally Posted by gast3 View Post
    is their a special place i should put that above ^^
    As I said. In the .htaccess file in the root folder of the domain (provided you have linux and not windows hosting)
    Signature Under Construction.

  20. #20
    Join Date
    Mar 2008
    Posts
    35
    Quote Originally Posted by stu2 View Post
    As I said. In the .htaccess file in the root folder of the domain (provided you have linux and not windows hosting)
    When i try making a :.htaccess
    in my FTP thing it says this file type aint allowed so i cant upload it =(

  21. #21
    Join Date
    Jun 2002
    Location
    New York, USA
    Posts
    180
    Quote Originally Posted by gast3 View Post
    When i try making a :.htaccess
    in my FTP thing it says this file type aint allowed so i cant upload it =(
    Are you using shared hosting? Is it linux or windows?
    EZHostz.Biz (Established in 2003) a DotJunction.Com Company.
    EZHostz.Biz <-> Reseller Info Domain Name Sales, WebHosting, Email Only Hosting, & Much More.
    Providers of Directi & Enom Reseller Accounts.

  22. #22
    Join Date
    Mar 2008
    Posts
    35
    Quote Originally Posted by ebay-nut View Post
    Are you using shared hosting? Is it linux or windows?
    im using the host:

    www.gigacities.net

    i think its shared hosting? check for me pl0x?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •