Results 1 to 12 of 12
  1. #1
    Join Date
    Feb 2006
    Posts
    74

    New VPS but Wrong Time?

    I just got another VPS (first one's host decided to quit hosting) and the time the server shows (entering "date" via ssh) is exactly 24 hours in advance. The time is correct but it shows up one day forward.

    It has cPanel/WHM and when I try to change the date it won't allow me. I've also tried via the date command in ssh but get an access restricted message (or something to that extent).

    Thanks.

  2. #2
    Join Date
    Jan 2007
    Location
    Miami Beach, FL, USA
    Posts
    764
    You cannot change the time on a VPS, they all use the time set on the node. You can however change the time-zone and ask your host if their node has the correct time set.
    Website Design and Marketing in France
    www.SagaNET.fr

  3. #3
    Join Date
    Apr 2007
    Location
    New York
    Posts
    422
    Yes, As eclouds said, that is something that has to be taken care of by the host. Just ask the host to run the following script.
    Code:
    ntpdate time.nist.gov
    If your host runs this script, it should correct the main server node time, then all you have to do is make sure your timezone is set correctly.

  4. #4
    Join Date
    Feb 2006
    Posts
    74
    Alright cool, thanks for the info, I'll let the host know.

  5. #5
    Join Date
    Apr 2007
    Location
    New York
    Posts
    422
    No Problem, That should take care of the problem, IF it is on their site.

  6. #6
    If you have a time zone setting, make sure its set correctly.
    FluidVM :: Manage Xen PV, Xen HVM and OpenVZ
    Multi-Hypervisor, Extensible Virtualization Platform :: Website :: User Forums ::
    Simple Browser based UI-Simple User VPS Control Panel!

  7. #7
    Join Date
    Feb 2006
    Posts
    74
    Quote Originally Posted by binarykarma View Post
    If you have a time zone setting, make sure its set correctly.
    I have it set to America/Chicago and get Fri Apr 4 22:33:09 CDT 2008.

  8. #8
    Join Date
    Jan 2003
    Location
    U.S.A.
    Posts
    3,911
    I am guessing your using openvz? You can ask your host to also do the following...

    Stop VE vzctl stop 101

    in HD node, run:

    vzctl set 101 --capability sys_timen --save

    Start VE: vzctl start 101

    Enter VE: vzctl enter 101

    mv /etc/localtime /etc/localtime.old
    ln -s /usr/share/zoneinfo/EST5EDT /etc/localtime

  9. #9
    Join Date
    May 2007
    Location
    Chicago
    Posts
    322
    I assume your VPS provider is using either Virtuozzo or OpenVZ. This is one of the differences between those and Xen - with Xen, the system clock is virtualized as well, so you can control it via NTP from inside a virtual machine. Definitely a benefit if you have an application that requires accurate clock synchronization.

    One comment on getting the host to run ntpdate - that only resets the clock at the current time. Over time, it will drift and become inaccurate again. It's best to have the host run NTP as a service on the main server node so that they time is regularly synced.
    Panopta | Never Blinks
    Advanced Server Monitoring and Outage Management Solutions

    http://www.panopta.com | sales@panopta.com

  10. #10
    open a ticket with your host. my host responds quick

  11. #11
    Join Date
    Feb 2006
    Posts
    74
    Quote Originally Posted by mohd08 View Post
    open a ticket with your host. my host responds quick
    I did and they suggested a few things that I tried and had no luck with. They haven't replied in a whole day so I guess I'll reply again.

  12. #12
    Join Date
    Feb 2006
    Posts
    74
    Thanks everyone, support took care of it.

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •