Results 1 to 16 of 16
  1. #1

    I need help with Mod_Rewrite (Enable It)

    Hello

    I have a VPS and I need to enable mod_rewrite.

    Here is my PHP Info: http://techguyboy.net/phpinfo.php

    I read a tutorial but I just don't get it. I would appreciate if you could help me out. I need it for my Wordpress blog.

    Thanks

  2. #2
    Join Date
    Jan 2006
    Location
    Athens, Greece
    Posts
    1,479
    Find your httpd.conf file. open it and search for a line:
    #LoadModule rewrite_module modules/mod_rewrite.so

    Remove the # and restart Apache. If you cannot find this line you need to recompile Apache to include the mod_rewrite.

  3. #3
    Quote Originally Posted by Steve_Arm View Post
    Find your httpd.conf file. open it and search for a line:
    #LoadModule rewrite_module modules/mod_rewrite.so

    Remove the # and restart Apache.
    I read this in a tutorial but I couldn't find it.


    If you cannot find this line you need to recompile Apache to include the mod_rewrite.
    What do you mean? How do I do this?
    Thanks

  4. #4
    Anybody? Please
    Thanks

  5. #5
    Join Date
    Aug 2007
    Location
    Greece
    Posts
    390
    Do you have a panel?If yes most of them give you a way of recompiling apache and his modules.If not and you are using a centos server you may install it by yum
    NOT a webhost!helping here just for the fun of it!
    G(r)eek inside.

  6. #6
    May I know how did you install your apache? is it through OS package, compiled from source or through control panel ?
    UltraUnix Internet Services
    Quality service since 2000!
    Reliability . Simplicity . Affordability

  7. #7
    I have Centos 5 with LxAdmin.

    I have no idea in how to recompile it. Can you guys post some instructions? Thanks

  8. #8
    Join Date
    Aug 2007
    Location
    Greece
    Posts
    390
    Ive just seen that you are not running apache but lighty.
    Lighttpd has its own mod_rewrite that you shou enable in its configuration file at the
    Code:
     				server.modules = (
    point.
    You could switch to apache through lxadmin and use the usual mod_rewrite module.

    *If you are trying to install one of the many free CMS that come with an .htaccess full of mod_rewrites the possibility is that they will not work with lighty unless you edit them.
    NOT a webhost!helping here just for the fun of it!
    G(r)eek inside.

  9. #9
    I will try that later tonight.

    Thanks

  10. #10
    ok. Where do I find those files?

    EDIT
    I think is this one. This is what I have in the file( lighttpd.conf): http://techguyboy.net/myhttpdconf.txt



    I need mod_rewrite for a Wordpress blog. Do you think it will work fine with Wordpress? If not, how can I change to Apache?


    Thanks
    Last edited by iJemuel; 03-24-2008 at 04:38 PM.

  11. #11
    Join Date
    Aug 2007
    Location
    Greece
    Posts
    390
    I dont have any lighttpd ATM so I can play with and my experience with lighty is really limited.From your configuration it seems like mod_rewrite is enabled.
    You could see this site fot instructions of how to use wordoress with lighty.
    If you want to switch to apache lxadmin ->server setup -> switch program and change at the webserver choose apache.
    NOT a webhost!helping here just for the fun of it!
    G(r)eek inside.

  12. #12
    After I choose Apache, what do I have to do?

    Which one is better? and faster?
    Thanks

  13. #13
    Join Date
    Aug 2007
    Location
    Greece
    Posts
    390
    In my opinion there is no better solution there is the solution that better fits your needs.
    Lighty is lighter and (probably) faster than apache (especialy in a vps with limited resources).
    On the other hand apache is widely used so you can find more modulesand you may have help by a lot more people.

    *To change to apache you should follow the instruction i gave you and press update.
    NOT a webhost!helping here just for the fun of it!
    G(r)eek inside.

  14. #14
    ok, I just chnaged to Apache but I am still having the same problems in my blog.

    My Blog
    HOME PAGE (WORKS FINE) http://techguyboy.net/
    Post Page (doesn't work) : http://techguyboy.net/uncategorized/hello-world.html

    This is what I have in my conf : http://techguyboy.net/myhttpdconf.txt


    Please help, I will pay.
    Thanks

  15. #15
    Join Date
    Dec 2007
    Location
    Jakarta
    Posts
    113
    Try this

    This line
    AllowOverride None

    Change to
    AllowOverride All

  16. #16
    I Got It Working!!!!

    Thanks, BoerChick

    I changed from Lighty to Apache and thanks to all of you I got it working. Thanks So Much!!!!!!!!!!


    Thanks!!!!!


    Thread Can Be Close.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •