Results 1 to 3 of 3
  1. #1

    writing log4j logs in shared server environment

    My situation is a familiar one :-) -- My web-app works perfectly well on my home-server. I am running on exactly the same setup as what is on my provider's shared servers -- same App server, JDK, database versions. Yet, the app does not have proper functionality on the host-server.

    So I turned on my logging functions (which also work perfectly on my home setup) but NO logs are generated on Lunar server.

    I filed a ticket and did get a response -- asking me to create a log-file with 777 permissions in public_html directory. I complied and did this by creating an empty file call abcde.log, and setting permissions to 777 (with my ftp tool). I also set the path name in log4j.lcf to /public_html/abcde.log. Needless to say I also rebuilt and deployed an updated war file. The app does run but still NO log-file (the original dummy file remains empty.)

    What am I missing? As it is, I have no other way of debugging (since everything works perfectly on my home setup.) Has anyone dealt with such issues?

  2. #2
    Here's a reply to my own post in case it helps someone else with a similar issue. I basically gave up on creating the log4j file and instead wrote logs into the database. At least that worked.

  3. #3
    Join Date
    Feb 2003
    Location
    Canada
    Posts
    958
    Quote Originally Posted by new_berlin View Post
    I also set the path name in log4j.lcf to /public_html/abcde.log
    Is this correct? That absolute path name doesn't look right at all. Did you try providing the FULL absolute path name, or maybe a proper relative one?

    Good to see you were able to work around the problem anyways.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •