Results 1 to 10 of 10
  1. #1

    Csf eror help me

    dear
    I have a eror in csf
    how can i solved this problem ?


    ConfigServer Security & Firewall - csf v3.11

    Restarting csf...

    Flushing chain `INPUT'
    Flushing chain `FORWARD'
    Flushing chain `OUTPUT'
    Restarting bandmin acctboth chains for cPanel
    iptables LKM ip_tables missing so this firewall cannot function unless you enable MONOLITHIC_KERNEL in /etc/csf/csf.conf
    Error: aborted, at line 156


    thanks
    Colocation, Dedicated Server, Cloud Services

  2. #2
    Join Date
    Jan 2008
    Location
    United Kingdom
    Posts
    414
    Set 'MONOLITHIC_KERNEL' to 1 in /etc/csf/csf.conf.

  3. #3
    Quote Originally Posted by Sam Robertson View Post
    Set 'MONOLITHIC_KERNEL' to 1 in /etc/csf/csf.conf.
    we do it but after restart vps , our vps down
    Colocation, Dedicated Server, Cloud Services

  4. #4
    Join Date
    May 2006
    Posts
    1,398
    you need to make sure that you have selected the proper ETH device which is usually venet or venet0:0 ever how your network has it setup. And sometimes your provider may not have the kernel setup properly, have needed modules, or something. I know on my vps provider I had to have him add and adjust things on the vps nodes I setup csf on.

  5. #5
    Join Date
    Mar 2008
    Location
    kolkata, India
    Posts
    102
    If you get iptables errors when trying to start csf on a VPS (and have set MONOLITHIC_KERNEL to 1) then you most likely have missing iptables modules for your VPS.

    If your hosting provider wants to know how to configure iptables correctly on a VPS server, then you should point them to this Virtuosso FAQ and have them follow it (plus to add ip_conntrack_ftp to the list of required modules):
    http://kb.swsoft.com/article_117_746_en.html

    csf requires at least these iptables modules:

    ip_tables
    ipt_state
    ipt_multiport
    iptable_filter
    ipt_limit
    ipt_LOG
    ipt_REJECT
    ipt_conntrack
    ip_conntrack
    ip_conntrack_ftp
    iptable_mangle

    If you suffer from "memory allocation" errors with iptables on a VPS, make sure that your numiptent setting (as mentioned in the Virtuozzo FAQ) is set sufficiently high.

    Note that the SMTP_BLOCK option does not work on a VPS as the Virtuozzo kernel doesn't support the ipt_owner iptables module.
    Sysfirm
    So you think your server is secure?
    Try our security Service
    With SysFirm

  6. #6
    Join Date
    Sep 2007
    Posts
    815
    I checked csf.conf and there is no MONOLITHIC_KERNEL option Im having the same problem now
    All things work together for the good of those who love God - Romans 8:28

  7. #7
    Join Date
    Feb 2004
    Location
    USA
    Posts
    1,571
    This is from the configserver website:

    Supported and Tested Virtual Servers
    **Virtuozzo
    **OpenVZ
    VMware
    UML
    Xen
    MS Virtual Server

    (** requires correct iptables configuration on host server)

    Did you try to contact your VPS provider and see if they loaded the correct iptables?

    Cheers

  8. #8
    Join Date
    Jul 2009
    Posts
    178
    restarting iptables and restarting csf would have resolved your issues.

  9. #9
    If you had made MONOLITHIC_KERNEL enable on the VPS server then restart your firewall. After that check firewall which ports to open and close all remaining port numbers.
    Support Facility | 24/7 web hosting technical support services
    Technical support | Server management | Data migration

    Technical Articles

  10. #10
    Join Date
    Aug 2009
    Location
    Bangalore
    Posts
    59
    for VPS, ethernet device should be "venet0". if you set etho, then it causes the VPS down.


    Thanks,
    Mike

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •