hosted by liquidweb


Go Back   Web Hosting Talk : Web Hosting Main Forums : Hosting Security and Technology : fsock
Reply

Forum Jump

fsock

Reply Post New Thread In Hosting Security and Technology Subscription
 
Send news tip View All Posts Thread Tools Search this Thread Display Modes
  #1  
Old 03-14-2008, 08:57 PM
Calibaba Calibaba is offline
Web Hosting Master
 
Join Date: Jan 2007
Posts: 688

fsock


Cannot send mail via php mail send


Warning: fsockopen() [function.fsockopen]: unable to connect to localhost:25 in /home/user/public_html/smtpmail/class.smtp.php on line 105



How do I correct this? I'm using Cpanel with php 4.4.8, apache 2.2, mod suphp



Sponsored Links
  #2  
Old 03-14-2008, 09:17 PM
Calibaba Calibaba is offline
Web Hosting Master
 
Join Date: Jan 2007
Posts: 688
I'm also getting error code -12263 on another domain

Apache error logs shows

[Fri Mar 14 20:16:45 2008] [error] [client 65.19.80.73] Invalid method in request \x16\x03\x01

  #3  
Old 03-14-2008, 10:24 PM
Tim Greer Tim Greer is offline
<insert something witty>
 
Join Date: Apr 2000
Location: California
Posts: 3,051
Make sure you allow connections on port 25, that local SMTP is allowed and it's running. Also, make sure you have this enabled for PHP (check php.ini or phpinfo()'s output to see).

The "Invalid method in request" error is likely unrelated to the SMTP issue, are you reporting two different issues for two different sites?

Sponsored Links
  #4  
Old 03-15-2008, 12:14 AM
Calibaba Calibaba is offline
Web Hosting Master
 
Join Date: Jan 2007
Posts: 688
[Fri Mar 14 23:13:30 2008] [error] [client 65.19.80.73] Invalid method in request \x16\x03\x01

Thats for another domain

  #5  
Old 03-15-2008, 05:29 AM
david510 david510 is offline
Web Hosting Master
 
Join Date: Oct 2004
Location: Kerala, India
Posts: 4,708
If you have installed any firewall program such as apf/csf make sure the smtp related settings are done properly.

__________________
David | www.cliffsupport.com
Affordable Server Management Solutions sales AT cliffsupport DOT com
CliffWebManager | Access WHM from iPhone and Android

  #6  
Old 03-15-2008, 05:44 AM
UltraUnix UltraUnix is offline
Junior Guru Wannabe
 
Join Date: Oct 2006
Posts: 34
Apf configuration is at /etc/apf/conf.apf

Look for IG_TCP_CPORTS in the file and make sure port 25 is listed in it.

check if exim is running or not with
service exim status

__________________
UltraUnix Internet Services
Quality service since 2000!
Reliability . Simplicity . Affordability

  #7  
Old 03-17-2008, 08:42 AM
applicurearun applicurearun is offline
WHT Addict
 
Join Date: Mar 2008
Location: kolkata, India
Posts: 102
After restart apf you can try the following:

Stop EXIM
kill all exim process running on top
kill all imap process running on top
start EXIM

__________________
Sysfirm
So you think your server is secure?
Try our security Service
With SysFirm

Reply

Related posts from TheWhir.com
Title Type Date Posted


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump
Login:
Log in with your username and password
Username:
Password:



Forgot Password?
Advertisement:
Web Hosting News:



 

X

Welcome to WebHostingTalk.com

Create your username to jump into the discussion!

WebHostingTalk.com is the largest, most influentual web hosting community on the Internet. Join us by filling in the form below.


(4 digit year)

Already a member?