Results 1 to 8 of 8
  1. #1

    MPM prefork question

    I recompiled apache on my server but i never checked the "mpm prefork (recommended by apache)" option. So a few days ago I ask a server admin about if i needed that or not? I told him to go ahead and recompile it in there. So today I checked apache logs and got these

    ar 12 20:13:51 host kernel: httpd[6806]: segfault at 000000000000000f rip 0000002a9a56287e rsp 0000007fbffff090 error 4
    Mar 12 20:13:58 host kernel: httpd[6861]: segfault at 000000000000000f rip 0000002a9a56287e rsp 0000007fbffff0a0 error 4
    Mar 12 20:14:03 host kernel: httpd[6804]: segfault at 000000000000000f rip 0000002a9a56287e rsp 0000007fbffff090 error 4
    Mar 12 20:14:08 host kernel: httpd[6890]: segfault at 000000000000000f rip 0000002a9a56287e rsp 0000007fbffff0a0 error 4
    Mar 12 20:14:12 host kernel: httpd[6776]: segfault at 000000000000000f rip 0000002a9a56287e rsp 0000007fbffff0a0 error 4
    Mar 12 20:14:14 host kernel: httpd[6923]: segfault at 000000000000000f rip 0000002a9a56287e rsp 0000007fbffff090 error 4
    Mar 12 20:14:57 host kernel: httpd[6955]: segfault at 000000000000000f rip 0000002a9a56287e rsp 0000007fbffff0a0 error 4
    Is this related to the MPM prefork? Do you even need to check that box (mpm) to do settings like maxclient, maxchildprocess etc etc?

    I did my own googling of the problem I some said it was because of php and/or hardware (ram). But that server admin guy says it's most likely the mpm prefork. Anyone have thoughts about this?

  2. #2
    Join Date
    Apr 2003
    Location
    San Jose, CA.
    Posts
    1,622
    I'm a little surprised by that.

    If you're not using the prefork MPM (which is by far the most common, and standard) what MPM are you using?
    Daved @ Lightwave Networking, LLC.
    AS1426 https:/www.lightwave.net
    Primary Bandwidth: EGIHosting (NLayer, NTT, HE, Cogent)
    Xen PV VPS Hosting

  3. #3
    When i upgraded to apache 2.2, i didn't check that mpm box. Weird...i even added maxclient etc etc, into the httpd.conf file and i thought it was working. But now it's set on mpm prefork. So it's not the mpm problem?

  4. #4
    Mar 13 19:59:53 host kernel: httpd[3736]: segfault at 000000000000000f rip 00000 02a9a56287e rsp 0000007fbfffecf0 error 4
    Mar 13 19:59:55 host kernel: httpd[3737]: segfault at 000000000000000f rip 00000 02a9a56287e rsp 0000007fbfffed00 error 4
    Mar 13 19:59:59 host kernel: httpd[3708]: segfault at 000000000000000f rip 00000 02a9a56287e rsp 0000007fbfffed00 error 4
    Mar 13 20:00:06 host kernel: httpd[3838]: segfault at 000000000000000f rip 00000 02a9a56287e rsp 0000007fbfffed00 error 4
    Mar 13 20:00:06 host named[16240]: lame server resolving '61.225.8.124.list.dsbl .org' (in 'dsbl.org'?): 204.13.249.76#53
    Mar 13 20:00:06 host named[16240]: lame server resolving '61.225.8.124.list.dsbl .org' (in 'dsbl.org'?): 91.198.22.76#53
    Mar 13 20:00:18 host kernel: httpd[3903]: segfault at 000000000000000f rip 00000 02a9a56287e rsp 0000007fbfffed00 error 4
    Mar 13 20:00:27 host kernel: httpd[3805]: segfault at 000000000000000f rip 00000 02a9a56287e rsp 0000007fbfffed00 error 4
    Mar 13 20:00:28 host kernel: httpd[3840]: segfault at 000000000000000f rip 00000 02a9a56287e rsp 0000007fbfffed00 error 4
    I got this error, and my websites don't load anymore. Anyone know what that's about? I restarted apache, html pages with php, but anything digging through mysql will not start...

    is it a mysql problem and which logs do I check?

    edit: try restarting mysql and got this error

    /usr/bin/mysqladmin: connect to server at 'localhost' failed error: 'Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)' Check that mysqld is running and that the socket: '/var/lib/mysql/mysql.sock' exists! mysql has failed, please contact the sysadmin (result was "Warning, no valid mysql.sock file found.mysql has failed").

  5. #5
    How do you edit a post here? Sorry if it seems like i'm double posting, there's no edit button anymore for some reason.

    Mar 13 21:14:01 host kernel: Firewall: *UDP_IN Blocked* IN=eth0 OUT= MAC=00:14:d1:13:cf:b6:00:0f:f8:e6:a8:00:08:00 SRC=97.82.22.230 DST=67.225.195.87 LEN=304 TOS=0x00 PREC=0x00 TTL=118 ID=9485 PROTO=UDP SPT=500 DPT=500 LEN=284
    Mar 13 21:14:02 host kernel: Firewall: *UDP_IN Blocked* IN=eth0 OUT= MAC=00:14:d1:13:cf:b6:00:0f:f8:e6:a8:00:08:00 SRC=97.82.22.230 DST=67.225.195.87 LEN=304 TOS=0x00 PREC=0x00 TTL=118 ID=9589 PROTO=UDP SPT=500 DPT=500 LEN=284
    Mar 13 21:14:04 host kernel: Firewall: *UDP_IN Blocked* IN=eth0 OUT= MAC=00:14:d1:13:cf:b6:00:0f:f8:e6:a8:00:08:00 SRC=97.82.22.230 DST=67.225.195.87 LEN=304 TOS=0x00 PREC=0x00 TTL=118 ID=9629 PROTO=UDP SPT=500 DPT=500 LEN=284
    Mar 13 21:14:08 host kernel: Firewall: *UDP_IN Blocked* IN=eth0 OUT= MAC=00:14:d1:13:cf:b6:00:0f:f8:e6:a8:00:08:00 SRC=97.82.22.230 DST=67.225.195.87 LEN=304 TOS=0x00 PREC=0x00 TTL=118 ID=10259 PROTO=UDP SPT=500 DPT=500 LEN=284
    Mar 13 21:14:16 host kernel: Firewall: *UDP_IN Blocked* IN=eth0 OUT= MAC=00:14:d1:13:cf:b6:00:0f:f8:e6:a8:00:08:00 SRC=97.82.22.230 DST=67.225.195.87 LEN=304 TOS=0x00 PREC=0x00 TTL=118 ID=10912 PROTO=UDP SPT=500 DPT=500 LEN=284
    Is this my csf firewall or is that an error?

  6. #6
    Join Date
    Jan 2006
    Location
    Athens, Greece
    Posts
    1,479
    Nice admin you got there.
    For Apache disable PHP module and see if the errors come up. If so, then probably
    you have a threaded module and PHP cannot work with it.
    Else revert to previous apache installation.

  7. #7
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    azn_romeo_4u,

    You will need to recompile apache/php.
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  8. #8
    =D thank you, I recompiled and I don't see that error anymore. But is about that other error

    Mar 13 21:14:01 host kernel: Firewall: *UDP_IN Blocked* IN=eth0 OUT= MAC=00:14:d1:13:cf:b6:00:0f:f8:e6:a8:00:08:00 SRC=97.82.22.230 DST=67.225.195.87 LEN=304 TOS=0x00 PREC=0x00 TTL=118 ID=9485 PROTO=UDP SPT=500 DPT=500 LEN=284
    Mar 13 21:14:02 host kernel: Firewall: *UDP_IN Blocked* IN=eth0 OUT= MAC=00:14:d1:13:cf:b6:00:0f:f8:e6:a8:00:08:00 SRC=97.82.22.230 DST=67.225.195.87 LEN=304 TOS=0x00 PREC=0x00 TTL=118 ID=9589 PROTO=UDP SPT=500 DPT=500 LEN=284
    Mar 13 21:14:04 host kernel: Firewall: *UDP_IN Blocked* IN=eth0 OUT= MAC=00:14:d1:13:cf:b6:00:0f:f8:e6:a8:00:08:00 SRC=97.82.22.230 DST=67.225.195.87 LEN=304 TOS=0x00 PREC=0x00 TTL=118 ID=9629 PROTO=UDP SPT=500 DPT=500 LEN=284
    Mar 13 21:14:08 host kernel: Firewall: *UDP_IN Blocked* IN=eth0 OUT= MAC=00:14:d1:13:cf:b6:00:0f:f8:e6:a8:00:08:00 SRC=97.82.22.230 DST=67.225.195.87 LEN=304 TOS=0x00 PREC=0x00 TTL=118 ID=10259 PROTO=UDP SPT=500 DPT=500 LEN=284
    Mar 13 21:14:16 host kernel: Firewall: *UDP_IN Blocked* IN=eth0 OUT= MAC=00:14:d1:13:cf:b6:00:0f:f8:e6:a8:00:08:00 SRC=97.82.22.230 DST=67.225.195.87 LEN=304 TOS=0x00 PREC=0x00 TTL=118 ID=10912 PROTO=UDP SPT=500 DPT=500 LEN=284
    Is that CSF firewall working or it's an actual error?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •