Results 1 to 9 of 9
  1. #1
    Join Date
    Feb 2002
    Location
    The Netherlands
    Posts
    308

    monitoring smtp/pop3 with mrtg

    Hi all,

    I'm running mrtg on the famous blue box and wonder how I can create a script which tells mrtg to monitor sendmail (smtp/pop3/files in que)

    I found the prog mailstats but that doesnt want to run for me.
    Can some cobalt/mrtg guru shed some light on this. I suspect cobalt having the standard elited to the difference and that is causing the problem.

    Any tips and tricks would be very welcome...

    Rob
    http://www.HaVa.nl
    Reliable hosting and Colocation

  2. #2
    Join Date
    Apr 2002
    Location
    Queensland, AUSTRALIA
    Posts
    11
    Hi Rob,

    Take a look at Stat.pl Version 1.2
    visit : http://www.bursztein.net/prog/stat/index.html

    this script will output active pop3/smtp/imap sessions (plus much more) for use in MRTG

    I have it setup on a RaQ4i and it works well.

    Cheers,

    Albert
    www.coasthost.net

  3. #3
    Join Date
    Feb 2002
    Location
    The Netherlands
    Posts
    308

    Wink

    Thanks !!!!!!!!!!!!!!!!!!
    http://www.HaVa.nl
    Reliable hosting and Colocation

  4. #4
    Join Date
    Feb 2002
    Location
    The Netherlands
    Posts
    308

    Unhappy

    Thanks again. However mail (smtp/pop3) you are refering to doesn't seem to work for me here. Still there goes a LOT of mail through the server no stats.....

    Any hints ???
    http://www.HaVa.nl
    Reliable hosting and Colocation

  5. #5
    Join Date
    Apr 2002
    Location
    Queensland, AUSTRALIA
    Posts
    11
    the pop3 and smtp graphs don't necessarily show every instance.

    it has to be an established connection when the script is run, so it can miss it.

    from shell type: netstat -tn

    you will see that connections aren't always in the established state, and that is what the stat.pl script looks for.

    Maybe your problem is something else though, does the script work for the other graphs - ftp/ssh/http etc?
    www.coasthost.net

  6. #6
    Join Date
    Feb 2002
    Location
    The Netherlands
    Posts
    308

    *

    Only httpd works. But ftp/ssh don't even work when there is an established connection....

    Strange..
    http://www.HaVa.nl
    Reliable hosting and Colocation

  7. #7
    Join Date
    Apr 2002
    Location
    Queensland, AUSTRALIA
    Posts
    11
    Hi Rob,

    Sounds strange.

    A couple of questions/points:-
    do you have ssh/ftp etc running on the standard ports?
    is the stat.pl script set for Linux and not BSD?
    Are you running standard cobalt sendmail?

    cheers,

    Albert
    www.coasthost.net

  8. #8
    Join Date
    Feb 2002
    Location
    The Netherlands
    Posts
    308
    Originally posted by CoastHost
    Hi Rob,

    Sounds strange.

    A couple of questions/points:-
    do you have ssh/ftp etc running on the standard ports?
    is the stat.pl script set for Linux and not BSD?
    Are you running standard cobalt sendmail?

    cheers,

    Albert
    Standard sendmail
    ssh/ftp running on standard ports.

    only i think i have forgotten to set it for linux.... might be the case let me check.....

    Thanks in advance albert.
    http://www.HaVa.nl
    Reliable hosting and Colocation

  9. #9
    Join Date
    Feb 2002
    Location
    The Netherlands
    Posts
    308
    Still nothing.......
    http://www.HaVa.nl
    Reliable hosting and Colocation

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •