Results 1 to 4 of 4

Thread: two issues

  1. #1
    Join Date
    Jan 2007
    Posts
    688

    two issues

    A couple of issues here.


    Details:
    The php file that is presenting the problem is part of the mailhandler module of a Drupal CMS. This php file is called as a result of a cron job that runs every 15 minutes. The script that is run from the cron job is:
    /home/user/public_html/lia/scripts/cron-curl.sh
    As you can see the script calls the following php file:
    /home/user/public_html/lia/liacron.php
    This in turn calls all Drupal modules 'cron' handlers. This eventually leads to the the problem php script in:
    /home/user/public_html/lia/modules/mailhandler/mailhandler.module

    Since there is an error I get an email every 15 minutes with the following subject and body:
    Subject: Cron /home/user/public_html/lia/scripts/cron-curl.sh
    Body:

    Fatal error: Call to undefined function imap_open() in /home/user/public_html/lia/modules/mailhandler/mailhandler.module on line 16

    I do have IMAP compiled and it shows up as green in whm status. How can I go about correcting this issue?


    Second problem is with Ruby:

    Ruby on Rails error in application's production.log

    The error message in the log file contains:
    MissingSourcefile (no such file to load)
    this may be caused by a missing ruby gem, namely the one which provides access to the postgresql database, postgres-0.7.9



    Specs: Cpanel / Ruby Rails+Gems / Phpsuexec / PHP 5 / Centos 5

  2. #2
    Join Date
    Feb 2004
    Location
    New Zealand
    Posts
    1,202
    Drupal issue;

    Do a phpinfo and make sure imap is definately running alongside apache, Just because IMAP appears in the WHM status doesn't mean it is running 100%.

    Check your httpd error logs for imap errors.

    if yum is install on your system - yum install php-imap

    Good luck
    DigitalGoods.info
    FREE Shared, Mega Resellers + Dedicated Servers

  3. #3
    Join Date
    Jan 2007
    Posts
    688
    Thanks. Got imap fixed, but cannot get Ruby fixed. Any help on that would be appreciated

  4. #4
    Join Date
    Mar 2008
    Location
    kolkata, India
    Posts
    102
    Quote Originally Posted by Calibaba View Post
    ...but cannot get Ruby fixed. Any help on that would be appreciated
    what is the complete line of the log?
    MissingSourcefile (no such file to load) ....??

    like " ERROR MissingSourceFile: no such file to load -- irb from WEBrick "

    if you are experiencing same above issue then try to installing irb separately.
    --

    Thanks.
    Sysfirm
    So you think your server is secure?
    Try our security Service
    With SysFirm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •