Results 1 to 2 of 2
  1. #1
    Join Date
    Oct 2002
    Posts
    54

    Apache Config help w/Frontpage

    Hello All,

    I need some help figuring out what I'm doing wrong with my configuration for FP & Apache. I know FP is no longer supported on Linux, but it still works.

    In my httpd.conf file I have a reference to my domain configuration files:
    Include /myconf/hosting/*

    Then in that folder I have files for each domain that look like this:

    abc.com (file) contains:
    <VirtualHost www.abc.com>
    ServerAdmin [email protected]
    DocumentRoot /home/abc.com/www
    ServerName www.abc.com
    ScriptAlias /cgi-bin/ /home/abc.com/www/cgi-bin/
    </VirtualHost>


    Then in /usr/local/frontpage I have:
    www.abc.com:80.cnf (file) contains:
    vti_encodingR|utf8-nl
    vti_logging:1
    servertype:apache-fp
    sendmailcommand:/usr/sbin/sendmail
    authoring:enabled
    extenderversion:5.0.2.2634
    frontpageroot:/usr/local/frontpage/version5.0
    serverconfig:/etc/httpd/conf/httpd.conf
    serverconfig:/usr/local/frontpage/conf/abc.com


    Finally the abc.com file located in /usr/local/frontpage/conf/ has:

    Port 80
    ResourceConfig /dev/null
    AccessConfig /dev/null
    ServerRoot "/etc/httpd"

    NameVirtualHost 127.0.0.1

    <VirtualHost 127.0.0.1:80>
    ServerName www.abc.com
    DocumentRoot /home/abc.com/www
    <Directory "/home/abc.com/www">
    Options Indexes FollowSymLinks
    AllowOverride AuthConfig Limit Indexes Options
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>

    <VirtualHost 127.0.0.1:80>
    ServerName www.abc.com
    DocumentRoot /home/abc.com/www
    <Directory "/home/abc.com/www">
    Options Indexes FollowSymLinks
    AllowOverride AuthConfig Limit Indexes Options
    Order allow,deny
    Allow from all
    </Directory>
    </VirtualHost>


    Whenevr I try to install a new website or update the existing ones I get errors. Additionally it also doesn't allow frontpage to connect on all of the sites, some yes... but with strange messages. Can anyone tell me the proper way to configure this?

    Thanks!
    Thanx!

    Joey

  2. #2
    Hi Joey,

    Is apache loading the frontpage modules?

    Do you have something like the following in your httpd.conf:
    LoadModule frontpage_module libexec/mod_frontpage.so
    AddModule mod_frontpage.c

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •