Results 1 to 8 of 8
  1. #1
    Join Date
    Nov 2006
    Posts
    459

    high load with skip-locking from whm

    Hi,

    the load of my server is high,

    i login whm and check the CPU/Memory/MySQL Usage

    User Domain %CPU %MEM MySQL Processes
    mysql 3.30 45.97 0.0
    Top Process %CPU 1.0 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/hostname.com.pid --skip-locking
    Top Process %CPU 0.7 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/hostname.com.pid --skip-locking
    Top Process %CPU 0.6 /usr/sbin/mysqld --basedir/ --datadir/var/lib/mysql --usermysql --pid-file/var/lib/mysql/hostname.com.pid --skip-locking
    the values are higher before,


    i want to ask what is skip-locking and if i add skip-locking in my.cnf,

    will the problem been improved? and will it take any effect or problem?



    thanks

  2. #2
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    It looks like you need to optimize your my.cnf. Skip-locking specifically is not causing your load.
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  3. #3
    Join Date
    Nov 2006
    Posts
    459
    Hi,


    i had try to run the ./tuning-primer.sh to check the mysql,



    for the first one value,

    i follow it's suggestion to set the "SLOW QUERIES" from 10 to 5,

    and edit the /etc/my.cnf
    log_slow_queries=/var/log/mysql-slow-queries.log
    long_query_time=5
    it is now
    Current long_query_time = 5 sec.
    You have 475 out of 4765104 that take longer than 5 sec. to complete
    The slow query log is enabled.
    but i can not find the mysql-slow-queries.log within /var/log/,

    i just winder if i need to create a file mysql-slow-queries.log in /var/log/ manually.



    thanks

  4. #4
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    touch the file manually.
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  5. #5
    Join Date
    Nov 2006
    Posts
    459
    Hi,david510,

    do you mean i cd to the folder /var/log,

    and type the command
    touch mysql-slow-queries.log
    to create the file?

    after creating it,should i do any chmod or chown for it?



    thanks

  6. #6
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    Yes correct. You can chown it to mysql.mysql and chmod it to 644.
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  7. #7
    Join Date
    Nov 2006
    Posts
    459
    Quote Originally Posted by david510 View Post
    Yes correct. You can chown it to mysql.mysql and chmod it to 644.

    Hi,

    i chown it mysql:mysql and chmod to 644,

    but there is no record within the file,

    how can check why it is?


    thanks

  8. #8
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    That means queries of that nature has not produced yet on the server.
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •