Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2002
    Posts
    45

    DNS Overview - some basic questions

    Hey all,

    I'm running into some conceptual problems with DNS servers and whatnot on a new dedicated I have.

    previously, I ran a dedicated server with a provider who had their own DNS servers.

    When I registered a new domain name, I set the DNS to my host's DNS and emailed them to point to my my server/ip. On my server, I could nslookup and whatever and it would resolve from my host's DNS's, I guess as it's DNS server lookup.

    So, I've moved to a new provider... and they asked me for a server name (server.domain.com) and DNS information.

    I gave them the name (server.domain.com) and the DNS servers that were assigned for that domain (dns3.register.com, dns4.register.com). I got the server setup...

    Now, I don't plan on using BIND and doing my own DNS... as I don't really see the major benefit... in that I can configure DNS (NAME A, MX) things at Register.com and Joker.com. and I figured it would just be an unncessary service running on the box.

    The problem is that I think I might have a problem with terms. What happened is that I got my new box... and now I can't resolve domains from the commandline and in scripts.

    In my Server setup:

    Primary Nameserver: dns3.register.com
    Secondary Nameserver: dns4.register.com

    In the terminal:

    bash-2.05a$ nslookup yahoo.com
    Note: nslookup is deprecated and may be removed from future releases.
    Consider using the `dig' or `host' programs instead. Run nslookup with
    the `-sil[ent]' option to prevent this message from appearing.
    Server: 216.21.234.72
    Address: 216.21.234.72#53

    Non-authoritative answer:
    *** Can't find yahoo.com: No answer

    Now, I just jotted off an email to my provider to get assistance... but I thought I wanted some to walk me through conceptually what I'm missing. Talk to me like I'm a 3 yr old, so to speak...

    Note, this is a CPanel/Redhat machine

    arn

  2. #2
    Join Date
    Aug 2002
    Location
    Beautiful suburb of Chicago
    Posts
    141
    What do you have in your /etc/resolv.conf file?

    George
    George Vuckovic - CEO & President, Tilted Planet, Ltd.
    Dedicated Servers, Dedicated Service, Definitely Tilted.
    Celebrating 16 years of top-notch hosting and innovation!
    Visit our 13 year old, obviously ancient site at TILTED.COM

  3. #3
    Join Date
    Aug 2002
    Posts
    45
    Originally posted by tilted
    What do you have in your /etc/resolv.conf file?

    George
    er... yeah - that's apparently was the problem. My host fixed it quickly. I guess unrelated to the DNS settings I was talking about above? Perhaps contributing to my confusion.

    arn

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •