Results 1 to 20 of 20
  1. #1
    Join Date
    Jun 2004
    Posts
    197

    Error when trying to run Apache Update (cPanel)

    I got a new server online today with a fresh installation of centos and cPanel:

    WHM 11.15.0 cPanel 11.18.1-R20683
    CENTOS Enterprise 5 i686 on standard - WHM X v3.1.0
    I have done the initial setup (ip's nameservers etc..) but when I try and run apache update I get the following:

    Premature end of script headers: /usr/local/cpanel/whostmgr/docroot/cgi/easyapache.pl: Please check /usr/local/cpanel/logs/error_log for the exact error.
    I look in the log file but it just repeatse the above error and doesnt supply any additional info.

    Any ideas?
    Last edited by strato; 02-16-2008 at 07:12 PM.

  2. #2
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    Do the following from shell.

    To update cpanel.
    /scripts/upcp --force

    To recompile apache/php
    /scripts/easyapache
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  3. #3
    Join Date
    Feb 2008
    Location
    Austin, Texas
    Posts
    272
    /scripts/upcp --force on a production system is somewhat likely to break it, so be sure you don't have anything mission critical on the system when you run it. (doesn't sound like you do.)
    ██ HermeTek Network Solutions
    ██ Network design, security, and implementation
    ██ BSD & Linux consulting, training, and hosting
    ██ https://www.hermetek.com | 1.866.235.1288

  4. #4
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    He has mentioned it is a fresh cpanel installation.

    Also upcp will not break the system.
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  5. #5
    Join Date
    Jun 2004
    Posts
    197
    Quote Originally Posted by david510 View Post
    Do the following from shell.

    To update cpanel.
    /scripts/upcp --force

    To recompile apache/php
    /scripts/easyapache
    I have tried to do a forced update about 3 times now...

    when I run easyapache from shell I get:

    [[email protected] ~]# /scripts/easyapache
    Can't locate YAML/Syck.pm in @INC (@INC contains: /usr/local/cpanel /var/cpanel/
    perl/easy /scripts /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/l
    ib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/
    i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /
    usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site
    _perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/per
    l5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i3
    86-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /
    usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_pe
    rl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/
    lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386
    -linux-thread-multi /usr/lib/perl5/5.8.8 .) at /usr/local/cpanel/Cpanel/DataStor
    e.pm line 11.
    BEGIN failed--compilation aborted at /usr/local/cpanel/Cpanel/DataStore.pm line
    11.
    Compilation failed in require at /var/cpanel/perl/easy/Cpanel/Easy/Utils.pm line
    14.
    BEGIN failed--compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy/Utils.pm
    line 14.
    Compilation failed in require at (eval 15) line 3.
    ...propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
    at /var/cpanel/perl/easy/Cpanel/Easy.pm line 16
    BEGIN failed--compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy.pm line 1
    6.
    Compilation failed in require at (eval 1) line 3.
    ...propagated at /usr/lib/perl5/5.8.8/base.pm line 85.
    BEGIN failed--compilation aborted at /var/cpanel/perl/easy/Cpanel/Easy/Apache.pm
    line 8.
    Compilation failed in require at /scripts/easyapache line 15.
    I also have another problem on the server that BIND wont install properly (http://www.webhostingtalk.com/showthread.php?t=671961). I see it as a separate problem but I dont know if it will mean anyting to you guys

  6. #6
    Join Date
    Jan 2008
    Location
    Internet
    Posts
    20
    What does your /etc/cpupdate.conf file say? You might wanna try /scripts/perlinstaller YAML:yck and re-run the update again.

  7. #7
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    Do the following.

    Enter cpan prompt
    Code:
    cpan
    from the cpan prompt execute
    Code:
    install YAML
    install YAML::Syck
    install YAML::Parser::Syck
    install YAML::Loader::Syck
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  8. #8
    Join Date
    Jun 2004
    Posts
    197
    Quote Originally Posted by david510 View Post
    Do the following.

    Enter cpan prompt
    Code:
    cpan
    from the cpan prompt execute
    Code:
    install YAML
    install YAML::Syck
    install YAML::Parser::Syck
    install YAML::Loader::Syck
    thanks, but that appears to have not changed anything. still getting the above errors

  9. #9
    Join Date
    Oct 2004
    Location
    Kerala, India
    Posts
    4,750
    Try changing the release of cpanel and perform upcp.
    David | www.cliffsupport.com
    Affordable Server Management Solutions sales AT cliffsupport DOT com
    CliffWebManager | Access WHM from iPhone and Android

  10. #10
    Did you ever get this problem fixed? I am suddenly having the same exact error on my VPS after upgrading cPanel.

  11. #11
    Join Date
    Aug 2007
    Posts
    39
    The same problem is now happening on one of my clients VPS's and im having trouble detecting the cause of the issue, and how to resolve it.

    Does anyone know how to fix this issue?

    Regards,
    Edward Tobia
    Administrator/Founder
    EuroSRV Hosting Solutions
    http://www.eurosrv.com

  12. #12
    Join Date
    Apr 2002
    Location
    USA
    Posts
    5,779
    /usr/local/cpanel/bin/checkperlmodules

    Read the output.
    Code:
    Then Upgrade YAML::Syck and File::Copy::Recursive:
    
               /scripts/realperlinstaller YAML::Syck
               /scripts/realperlinstaller File::Copy::Recursive
    Last edited by The3bl; 08-31-2008 at 08:35 PM.

  13. #13
    I'm still getting that errors. is there anybody can fix the problem? I've rebuild my vps but still have the same problem.
    Last edited by izwan00; 09-06-2008 at 08:39 AM.

  14. #14
    Join Date
    Apr 2002
    Location
    USA
    Posts
    5,779
    Contact your host and ask them to fix or contact cpanel and ask them to take a look.

  15. #15

    *

    Ok, i just fix it for one of our VPS:
    You have to check the Perl module missing.

    For example:

    Enter:
    Code:
    vi /usr/local/cpanel/logs/error_log
    It should say something like:
    Code:
    Acme::Spork version v0.0.8 required--this is only version v0.0.7  at /var/cpanel/perl/easy/Cpanel/Easy/Utils/BackGround.pm line 14.
    Now you know wich module is outdated.

    Enter:
    Code:
    cpan
    install Acme:Spork
    quit
    That's all.

  16. #16
    Reinstall Perl from cpanel and perform a upcp on stable release. This should fix your problem.
    www.24x7servermanagement.com
    Server Management, Server Security, Server Monitoring.
    India's Leading Managed Service Provider !! Skype: techs24x7

  17. #17
    I've seen this a couple of times now this week. cPanel released an update that requires 0.0.8 of Acme:pork, when the version is actually 0.0.7. Run the following to fix:

    /scripts/checkperlmodules

    This will fix it.

  18. #18
    Actually SSH into the server and go to /home/.cpan/ and delete the file FTPstats.yml and then try run cpan command with acm as mention before
    www.SURRENDERONLINE.com.au
    Perfect Solutions Every Time! Sydney Based :: Dedicated Servers :: Colocation :: Superior Support::Reseller Solutions

  19. #19
    Join Date
    Apr 2009
    Location
    inside wht
    Posts
    716
    Is it fixed , if not what is latest error log

  20. #20
    Yes, got fixed on a VPS, I had same issue:

    I commented a line "#CPANEL=never" in /etc/cpupdate.conf then upcp --force and it is done.
    Back after a long time!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •