Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2007
    Posts
    36

    iptables not working with CSF

    Hi,

    I have CSF installed on one of our server.

    CSF dont ban the IP and if manually it is done I get following error.
    ----------------
    csf -d 195.88.65.47
    Adding 195.88.65.47 to csf.deny and iptables DROP...
    iptables: Index of insertion too big
    DROP all opt -- in !lo out * 195.88.65.47 -> 0.0.0.0/0
    Error: iptables command [/sbin/iptables -v -I INPUT 2 -i ! lo -s 195.88.65.47 -j DROP] failed, at line 864
    -------------------
    Also iptables is not running on server.
    If status is checked it says its stopped.

    I have many sites on my server I dont want to get any downtime.

    Please let us know how can we fix this issue as soon as possible.

    I have tried reinstall CSF but still the issue remains same.

    Waiting for your reply.

  2. #2
    It seems you have problem with iptables. Try reinstalling iptables with yum. Also try starting iptables and see if you get any error.

  3. #3
    Join Date
    Dec 2005
    Posts
    3,077
    As mentioned, start the Iptables service and see if you have any errors:

    # service iptables start

    If this is on a vps you may need to execute "yum -y install module-init-tools" for IPTables to work correctly.

  4. #4
    Join Date
    Dec 2007
    Posts
    36
    Thanks for your reply.

    It is not VPS its shared server.

    If I try service iptables start it dont give any error.
    I get following when iptables is started.
    ------------------------------------
    Flushing firewall rules: [ OK ]
    Setting chains to policy ACCEPT: mangle filter [ OK ]
    Unloading iptables modules: [ OK ]
    --------------------------------------
    but if service is checked it says stopped.
    it says "Firewall is stopped."

    so how can I reinstall it without any problem on server if you suggest it?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •