Results 1 to 5 of 5
  1. #1
    Join Date
    Jan 2006
    Location
    Morocco
    Posts
    73

    high memery usage !!!!!!

    hello


    i have a quad core Intel XEON 5130 @ 1.60GHz . with 6giga now of memory . i have about 300 account in it . CENTOS Enterprise 4.6 installed .

    the probleme is that the memory server it used in totaly . after i was just 2Gb of ram , but sometimes the server lod arrive at 50% . for that i have added more memory (4Gb) , when i added it the memroy usage is always about 4giga sometimes about 3980Mb . the load is normal , but sometimes the server loas arrive at 50% or 60% (this is just in specific times) . after i have decided to add 2 Gb more , now is 6gb in the server . but also all the 6giag of ram is used , the load is normal but memory is all used , look to the top command


    Code:
     
    top - 02:55:26 up 1 day,  4:31,  1 user,  load average: 0.25, 0.30, 0.45
    Tasks: 157 total,   2 running, 154 sleeping,   0 stopped,   1 zombie
    Cpu(s):  6.5% us,  1.3% sy,  0.0% ni, 92.1% id,  0.1% wa,  0.0% hi,  0.0% si
    Mem:   6229508k total,  5995668k used,   233840k free,   213712k buffers
    Swap:  4192824k total,      224k used,  4192600k free,  4353968k cached
      PID USER      PR  NI %CPU    TIME+  %MEM  VIRT  RES  SHR S COMMAND
    14688 mysql     15   0   18   2:20.46  0.2 28312  14m 2788 S mysqld
    19367 nobody    15   0    4   0:00.33  0.4 64820  23m 3628 S httpd
    19318 nobody    17   0    3   0:01.17  0.4 67440  26m 3572 S httpd
    19882 nobody    15   0    3   0:00.13  0.4 62688  22m 3560 S httpd
    19873 nobody    16   0    3   0:00.22  0.4 67740  25m 3592 S httpd
    19178 nobody    15   0    1   0:00.60  0.0     0    0    0 Z httpd <defunct>
     2785 root      15   0    0   0:47.36  0.0     0    0    0 S kjournald
     3795 named     19   0    0   4:12.29  0.2 77372  10m 1944 S named
    19153 root      16   0    0   0:00.29  0.0  2120 1056  780 R top
    19329 nobody    15   0    0   0:00.64  0.4 65748  24m 4000 S httpd
    19364 nobody    15   0    0   0:00.28  0.4 64820  23m 4032 S httpd
        1 root      16   0    0   0:04.60  0.0  3476  548  468 S init
        2 root      RT   0    0   0:00.16  0.0     0    0    0 S migration/0
        3 root      34  19    0   0:00.28  0.0     0    0    0 S ksoftirqd/0
        4 root      RT   0    0   0:00.19  0.0     0    0    0 S migration/1
        5 root      34  19    0   0:00.46  0.0     0    0    0 S ksoftirqd/1
        6 root      RT   0    0   0:05.71  0.0     0    0    0 S migration/2
        7 root      34  19    0   0:01.07  0.0     0    0    0 S ksoftirqd/2
        8 root      RT   0    0   0:00.15  0.0     0    0    0 S migration/3
        9 root      34  19    0   0:00.19  0.0     0    0    0 S ksoftirqd/3
       10 root       5 -10    0   0:00.07  0.0     0    0    0 S events/0
       11 root       5 -10    0   0:00.01  0.0     0    0    0 S events/1
       12 root       5 -10    0   0:00.01  0.0     0    0    0 S events/2
       13 root       5 -10    0   0:00.01  0.0     0    0    0 S events/3
       14 root       9 -10    0   0:00.00  0.0     0    0    0 S khelper
       15 root      15 -10    0   0:00.00  0.0     0    0    0 S kacpid
       52 root       5 -10    0   0:00.00  0.0     0    0    0 S kblockd/0
       53 root       5 -10    0   0:00.00  0.0     0    0    0 S kblockd/1
       54 root       5 -10    0   0:00.00  0.0     0    0    0 S kblockd/2
       55 root       5 -10    0   0:00.00  0.0     0    0    0 S kblockd/3
       56 root      15   0    0   0:00.00  0.0     0    0    0 S khubd
       73 root      15   0    0   0:03.40  0.0     0    0    0 S pdflush
       74 root      15   0    0   0:27.65  0.0     0    0    0 S pdflush
       75 root      15   0    0   0:22.03  0.0     0    0    0 S kswapd0
       76 root      13 -10    0   0:00.00  0.0     0    0    0 S aio/0
       77 root       5 -10    0   0:00.00  0.0     0    0    0 S aio/1
       78 root       5 -10    0   0:00.00  0.0     0    0    0 S aio/2
    i have made so many tweeking to my.cnf . i have upgraded to apache 2.2.6 and php 5.2.5 , but the same result .

    any help for this strange situation !!!!!!
    From The

  2. #2
    Join Date
    Jul 2001
    Location
    Troy, Missouri USA
    Posts
    1,299
    I don't really see any thing wrong with the memory as it is being used by buffers and caches as it should be. This memory can still be used as needed elsewhere.

    Bob

  3. #3
    Join Date
    Jul 2004
    Location
    Athens, Greece
    Posts
    203
    Default top sorting is by CPU usage (descending), you may want to sort it by MEM usage (try: top -osize).
    SharkTECH Internet Services
    http://www.sharktech.net
    DDOS Firewalled Dedicated Servers
    Managed Services / IRC Allowed

  4. #4
    Join Date
    Jan 2006
    Location
    Morocco
    Posts
    73
    i have installed munin and i this is the graph for one day . (see attachement )

    is like the swap is not working . for some times the memory gone to 8 Gb in munin graph and swap not used !!!!!

    is this normal
    Attached Thumbnails Attached Thumbnails swap-day.png   memory-day.png  
    From The

  5. #5
    Join Date
    Nov 2001
    Location
    Ann Arbor, MI
    Posts
    2,978
    I thought we covered this in a different thread that you started? Linux uses available memory for caching and buffers.

    If you haven't used any swap, then you're probably okay as far as memory goes. It's normal for linux to overcommit memory. I think you want to concentrate on the active memory.
    -Mark Adams
    www.bitserve.com - Secure Michigan web hosting for your business.
    Only host still offering a full money back uptime guarantee and prorated refunds.
    Offering advanced server management and security incident response!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •