Results 1 to 14 of 14
  1. #1

    Lighttpd - backend died; we'll disable it for 5 seconds

    My log is filling up with errors + 500 internal displaying:

    2008-01-09 16:17:50: (mod_fastcgi.c.2703) fcgi-server re-enabled: unix:/tmp/php-fastcgi.socket-1
    2008-01-09 16:17:59: (mod_fastcgi.c.1731) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    2008-01-09 16:17:59: (mod_fastcgi.c.2885) backend died; we'll disable it for 5 seconds and send the request to another backend instead: reconnects: 0 load: 5
    2008-01-09 16:18:05: (mod_fastcgi.c.2703) fcgi-server re-enabled: unix:/tmp/php-fastcgi.socket-1
    2008-01-09 16:18:18: (mod_fastcgi.c.1731) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    2008-01-09 16:18:18: (mod_fastcgi.c.2885) backend died; we'll disable it for 5 seconds and send the request to another backend instead: reconnects: 0 load: 5
    2008-01-09 16:18:24: (mod_fastcgi.c.2703) fcgi-server re-enabled: unix:/tmp/php-fastcgi.socket-1
    2008-01-09 16:18:33: (mod_fastcgi.c.1731) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1


    I have tried all sorts of combos.

    Core2Duo 1 processor
    Lighttpd 1.4.18
    PHP 5.2.5
    xcache 1.2.1
    2gig ram


    fastcgi.server = ( ".php" =>
    ( "localhost" =>
    (
    "socket" => "/tmp/php-fastcgi.socket",
    "bin-path" => "/usr/local/php5/bin/php-cgi",
    "min-procs" => 2,
    "max-procs" => 6,
    "bin-environment" => (
    "PHP_FCGI_CHILDREN" => "10",
    "PHP_FCGI_MAX_REQUESTS" => "1000"
    )
    )
    )

  2. #2
    Join Date
    Jan 2008
    Location
    Atlanta, Ga, USA
    Posts
    35
    Quote Originally Posted by Gigaron View Post
    My log is filling up with errors + 500 internal displaying:

    2008-01-09 16:17:50: (mod_fastcgi.c.2703) fcgi-server re-enabled: unix:/tmp/php-fastcgi.socket-1
    2008-01-09 16:17:59: (mod_fastcgi.c.1731) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    2008-01-09 16:17:59: (mod_fastcgi.c.2885) backend died; we'll disable it for 5 seconds and send the request to another backend instead: reconnects: 0 load: 5
    2008-01-09 16:18:05: (mod_fastcgi.c.2703) fcgi-server re-enabled: unix:/tmp/php-fastcgi.socket-1
    2008-01-09 16:18:18: (mod_fastcgi.c.1731) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1
    2008-01-09 16:18:18: (mod_fastcgi.c.2885) backend died; we'll disable it for 5 seconds and send the request to another backend instead: reconnects: 0 load: 5
    2008-01-09 16:18:24: (mod_fastcgi.c.2703) fcgi-server re-enabled: unix:/tmp/php-fastcgi.socket-1
    2008-01-09 16:18:33: (mod_fastcgi.c.1731) connect failed: Connection refused on unix:/tmp/php-fastcgi.socket-1


    I have tried all sorts of combos.

    Core2Duo 1 processor
    Lighttpd 1.4.18
    PHP 5.2.5
    xcache 1.2.1
    2gig ram


    fastcgi.server = ( ".php" =>
    ( "localhost" =>
    (
    "socket" => "/tmp/php-fastcgi.socket",
    "bin-path" => "/usr/local/php5/bin/php-cgi",
    "min-procs" => 2,
    "max-procs" => 6,
    "bin-environment" => (
    "PHP_FCGI_CHILDREN" => "10",
    "PHP_FCGI_MAX_REQUESTS" => "1000"
    )
    )
    )
    You're using directives that are unsupported in your version of lighttpd. Maybe that's the problem.

    From:
    http://trac.lighttpd.net/trac/wiki/D...stCGI#examples
    Adaptive Process Spawning

    Note

    This feature is is no longer available as of 1.3.14.
    The first Pay-As-You-Go Backup Service.
    Unlimited Storage, Unlimited Repositories, Unlimited Users, WebSVN.
    No Registration! Instant Setup! PayPal.
    Unlimited Hosted Subversion www.8svn.com

  3. #3
    Join Date
    Dec 2006
    Posts
    477
    This error usually means there is a problem in a PHP script that is crashing out the PHP fast-cgi server process and lighttps is waiting for it to come back up.

    The best way to debug is to change your lighttpd configruation so that rather than spawning the fastcgi process it connects to an external running fastcgi process. Then run php in fastcgi server mode manually so you can see its error output and capture any core dumps etc.

  4. #4
    Quote Originally Posted by RBBOT View Post
    This error usually means there is a problem in a PHP script that is crashing out the PHP fast-cgi server process and lighttps is waiting for it to come back up.

    The best way to debug is to change your lighttpd configruation so that rather than spawning the fastcgi process it connects to an external running fastcgi process. Then run php in fastcgi server mode manually so you can see its error output and capture any core dumps etc.

    Can you please explain more on the procedures of setting up an external running fastcgi process?

    Please PM me if you can fix this problem for a fee.

    Thanks

  5. #5
    Join Date
    Nov 2005
    Location
    Michigan, USA
    Posts
    3,872
    Gigaron, try taking these steps.

    I'm assuming in this you are running lighty under the user 'lighttpd', so just replace lighttpd if you are not.

    mkdir -p /var/tmp/lighttpd
    chmod 770 /var/tmp/lighttpd
    chown lighttpd:lighttpd /var/tmp/lighttpd

    then change the socket path from /tmp/php-fastcgi.socket to /var/tmp/lighttpd/php-fastcgi.socket.

    That should fix it for you.


  6. #6
    Quote Originally Posted by devonblzx View Post
    Gigaron, try taking these steps.

    I'm assuming in this you are running lighty under the user 'lighttpd', so just replace lighttpd if you are not.

    mkdir -p /var/tmp/lighttpd
    chmod 770 /var/tmp/lighttpd
    chown lighttpd:lighttpd /var/tmp/lighttpd

    then change the socket path from /tmp/php-fastcgi.socket to /var/tmp/lighttpd/php-fastcgi.socket.

    That should fix it for you.
    Can I ask why does /var/tmp/ make a difference to /tmp/

    Thanks

  7. #7
    Join Date
    Nov 2005
    Location
    Michigan, USA
    Posts
    3,872
    It doesn't, but these are the steps I took when I was running lighttpd and ran into the same problem you had. I created a directory owned by the same user with full privileges and it seemed to fix it, have you tried it yet? Lighttpd had trouble with sockets in my /tmp directory.


  8. #8
    devonblzx, I just tried your suggestion. If the error comes up again, I'll post back here.

  9. #9
    Join Date
    Jul 2004
    Location
    Athens, Greece
    Posts
    203
    If the error re-appears, you might want to contact CretaForce. According to several posts I've seen, he seems quite experienced with Lighttpd
    SharkTECH Internet Services
    http://www.sharktech.net
    DDOS Firewalled Dedicated Servers
    Managed Services / IRC Allowed

  10. #10
    Quote Originally Posted by devonblzx View Post
    It doesn't, but these are the steps I took when I was running lighttpd and ran into the same problem you had. I created a directory owned by the same user with full privileges and it seemed to fix it, have you tried it yet? Lighttpd had trouble with sockets in my /tmp directory.

    I've tried it and I think its fixed. No errors in my log. If it ever comes back I'll let you know here. THanks

  11. #11
    After several months of it being fixed, it has come back today non-stop! Any solution?

    Need help desperately!

  12. #12
    Join Date
    Dec 2004
    Location
    Clemson
    Posts
    172
    Quote Originally Posted by psyxakias View Post
    If the error re-appears, you might want to contact CretaForce. According to several posts I've seen, he seems quite experienced with Lighttpd
    According to ^^ seems this guy might be able to help
    Brett Meadors

  13. #13
    Quote Originally Posted by Brett M View Post
    According to ^^ seems this guy might be able to help
    I've contacted the dude, and waiting for him to contact me back. Getting really desperate here!

  14. #14
    Hi! Has he responded anything?

    I have the same problem now

    Thanks in advance.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •