Results 1 to 11 of 11
  1. #1
    Join Date
    Sep 2006
    Posts
    79

    Request to fix my apache problem.

    I would like to Request to fix my apache problem.
    any one can do? I will pay paypal $5
    Please PM if you are interested.

  2. #2
    Join Date
    Sep 2005
    Location
    Frankfurt/Germany
    Posts
    29
    Why not describe your problem. Maybe you can save the cold, hard cash
    Managed Rootservers running FreeBSD: Mainlink Internet

  3. #3
    Join Date
    Mar 2003
    Posts
    12,540
    Moved To Systems Management Requests.
    .
    JoneSolutions.Com is on the net providing services and support 24/7 since 2001.
    .

  4. #4
    Join Date
    Sep 2006
    Posts
    79
    Thanks for rpely.

    The problem is I cannot restart the apache

    For example in Directadmin

    An error has occurred.

    Details
    /sbin/service httpd restart 2>&1


    [root@64 ~]# service httpd restart
    Stopping httpd: [FAILED]
    Starting httpd: [Thu Sep 13 04:48:05 2007] [warn] module php5_module is already loaded, skipping
    [Thu Sep 13 04:48:05 2007] [warn] module perl_module is already loaded, skipping
    [Thu Sep 13 04:48:05 2007] [warn] module mod_php5.c is already added, skipping
    fopen: No such file or directory
    httpd: could not open document config file /usr/local/directadmin/data/users/ps1 /httpd.conf







    Quote Originally Posted by mainlink View Post
    Why not describe your problem. Maybe you can save the cold, hard cash

  5. #5
    Join Date
    May 2006
    Location
    NJ, USA
    Posts
    6,391
    I can do it for 5$.

    Do you have AIM?
    simplywww: directadmin and cpanel hosting that will rock your socks

    Need some work done in a datacenter in the NYC area? NYC Remote Hands can do it.

  6. #6
    Join Date
    Sep 2004
    Location
    Flint, Michigan
    Posts
    5,765
    Looks like you tried to delete a user (or somehow a user was deleted) and the httpd.conf didn't update. If you open up your httpd.conf file and go to the bottom you will see a line to include the file listed:

    Code:
    /usr/local/directadmin/data/users/ps1 /httpd.conf
    You can comment out this line if you'd like by putting a # in front of it.

    The only other thing that seems a bit odd is that you have a space after ps1 which I'm not sure should be there. I'd check to see if that file exists, and if it does correct the line to point to it properly (possibly that space).
    Mike from Zoodia.com
    Professional web design and development services.
    In need of a fresh hosting design? See what premade designs we have in stock!
    Web design tips, tricks, and more at MichaelPruitt.com

  7. #7
    Join Date
    Sep 2006
    Posts
    79
    I have PM you my AIM
    I am waiting for your help

    Quote Originally Posted by Dougy View Post
    I can do it for 5$.

    Do you have AIM?

  8. #8
    Join Date
    Sep 2006
    Posts
    79
    SO great.

    Thanks.

    My apache is running now.

    But I still have the following warning:

    Starting httpd: [Thu Sep 13 04:48:05 2007] [warn] module php5_module is already loaded, skipping
    [Thu Sep 13 04:48:05 2007] [warn] module perl_module is already loaded, skipping
    [Thu Sep 13 04:48:05 2007] [warn] module mod_php5.c is already added, skipping

    It is due to I tried to upgrade php4 to php5 before.

    Do you know how to fix it ?


    Quote Originally Posted by dollar View Post
    Looks like you tried to delete a user (or somehow a user was deleted) and the httpd.conf didn't update. If you open up your httpd.conf file and go to the bottom you will see a line to include the file listed:

    Code:
    /usr/local/directadmin/data/users/ps1 /httpd.conf
    You can comment out this line if you'd like by putting a # in front of it.

    The only other thing that seems a bit odd is that you have a space after ps1 which I'm not sure should be there. I'd check to see if that file exists, and if it does correct the line to point to it properly (possibly that space).

  9. #9
    Join Date
    Sep 2004
    Location
    Flint, Michigan
    Posts
    5,765
    Those are just warning and won't hurt anything, but they are simple enough to fix.

    Basically you have more than on line loading your php5_module, perl_moduly, and mod_php5.c in your httpd.conf

    You want to look through it and find the duplicate lines, then comment out one of them (or as many as it takes so you only have one line actually being ran).

    PHP5 one is most likley:
    Code:
    LoadModule php5_module        /usr/lib/apache/libphp5.so
    Perl one should be something like:
    Code:
    LoadModule perl_module        modules/libperl.so
    And the php5.c is most likely:
    Code:
    AddModule mod_php5.c
    Mike from Zoodia.com
    Professional web design and development services.
    In need of a fresh hosting design? See what premade designs we have in stock!
    Web design tips, tricks, and more at MichaelPruitt.com

  10. #10
    Join Date
    Sep 2006
    Posts
    79
    Hi, dollar, Yuo are so great
    I appreciate your help

    The apache is running wihtout warning message.

    Can I help me another issue.

    My server host around 100 websites, most of them are inactive, but only one website has around10K unique and 110k page view.
    This always make my apache very busy (not responding) I see there are so many PID in httpd status

    my server:
    P4 3G Hz + 1G RAM

    here is my httpd setting

    Timeout 10
    KeepAlive On
    MaxKeepAliveRequests 0
    KeepAliveTimeout 3
    MinSpareServers 25
    MaxSpareServers 75
    StartServers 2
    MaxClients 150
    MaxRequestsPerChild 0

    Do you have any idea to modify this setting to suit my high traffic need ?


  11. #11
    I suggest you to add the apache module Mod_evasive instead of changing the existing settings.

    Mod_evasive apache module will help protect against people sending too many requests to the webserver in an attempt to flood it. If it detects too many connections the offending ip will be blocked from the accessing apache for This is especially useful when the server is continuously getting attacked. With this default configuration it will block the offending ip for 10 minutes. If it continues to try and flood mod_evasive will automatically add more time to this.

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •