Results 1 to 10 of 10
  1. #1
    Join Date
    May 2002
    Location
    The Netherlands
    Posts
    13

    PHP 4.2.2 on RAQ4?

    Hi, I would love to install PHP 4.2.2. on my RAQ4.

    Is it possible to install it from the source? If yes, how to that?

    I have currently installed the 4.1.2-3 package from PKGMaster.com, do i need to uninstall that one first?

    Thx already.

  2. #2
    Join Date
    Mar 2001
    Location
    Ireland
    Posts
    1,354
    Please look further down in this forum - I gave detailed instructions for this earlier today.
    Blacknight
    ICANN accredited domain registrar

  3. #3
    Join Date
    May 2002
    Location
    The Netherlands
    Posts
    13
    Owkee thx, found it!

    http://www.webhostingtalk.com/showth...threadid=61449


    Only one question left... Is it handy to uninstall the pkg from the pkgmaster first?

    What will happen if I don't uninstall....

    What do you think? Install from source? Or wait for a new PKG?

  4. #4
    Join Date
    Mar 2001
    Location
    Ireland
    Posts
    1,354
    I didn't uninstall any pkg versions before I did the upgrade (I had to do it twice as PHP went from 4.2.1 to 4.2.2 while I was doing the upgrade)
    you might end up with the binary having a different version to the standard script, but apart from that I can't see any real problems.

    Just be careful - make backups of both php.ini and httpd.conf before you do anything.
    It worked for me, but it might not for you, as my RAQ has a far from standard configuration.
    Blacknight
    ICANN accredited domain registrar

  5. #5
    Join Date
    May 2002
    Location
    The Netherlands
    Posts
    13
    k thx for your information, I make nightly backups of the server (including configurations (php.ini & httpd.conf)) nothing to worry about.

    If it compiles without problems, than the install should not be a problem to.

    If it worked out, I will drop a message.

  6. #6
    Join Date
    Mar 2001
    Location
    Ireland
    Posts
    1,354
    Originally posted by Frenck
    k thx for your information, I make nightly backups of the server (including configurations (php.ini & httpd.conf)) nothing to worry about.
    So do I, but I prefer to make a local backup as well, so that the server is only messed up for a couple of seconds at a time
    Blacknight
    ICANN accredited domain registrar

  7. #7
    Join Date
    May 2002
    Location
    The Netherlands
    Posts
    13
    Local backup is also present

    now i have got this error while compiling php 4.2.2

    checking for CURL in default path... not found
    configure: error: Please reinstall the libcurl distribution -
    easy.h should be in <curl-dir>/include/curl/


    ?! what to do....

    Also there is a an other question in my mind, What about the admin interface... it's using php to right? won't it be affected? Sinds php 4.2.2 has got register_globals turned off?

  8. #8
    Join Date
    Mar 2001
    Location
    Ireland
    Posts
    1,354
    The admin interface doesn't use PHP (unless on a RAQ 550)
    as for libcurl - locate and point it to it
    Blacknight
    ICANN accredited domain registrar

  9. #9
    Join Date
    May 2002
    Location
    The Netherlands
    Posts
    13
    thx for your quick reply!

    I've located curl:

    [root php-4.2.2]# locate libcurl
    /usr/lib/libcurl.so.2
    /usr/lib/libcurl.so.2.0.2


    Then used this configure line:

    './configure' '--prefix=/usr' '--with-apxs=/usr/sbin/apxs' '--with-gd' '--with-gettext=/usr' '--enable-safe-mode' '--with-config-file-path=/etc/httpd' '--with-exec-dir=/usr/bin' '--with-zlib' '--enable-magic-quotes' '--with-regex=system' '--with-ttf' '--with-db' '--with-gdbm' '--with-mbstring' '--with-mbstr-enc-trans' '--enable-track-vars' '--enable-wddx=shared' '--enable-mm=shared' '--enable-xml' '--enable-ftp' '--disable-debug' '--with-libdir=/usr/lib' '--with-db3' '--with-interbase=shared' '--with-pgsql=shared' '--with-ldap' '--with-imap' '--with-curl=/usr/lib' '--with-pdflib=shared'

    but still the same error message :'(

  10. #10
    Join Date
    Mar 2001
    Location
    Ireland
    Posts
    1,354
    Is libcurl available as a separate download? If it is download and install it. The RAQ installation might be missing something
    Have u checked for the file that it's asking for??
    Blacknight
    ICANN accredited domain registrar

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •