Results 1 to 18 of 18
  1. #1
    Join Date
    May 2001
    Location
    .
    Posts
    192

    cannot receive email : code 501 5.6.0

    I have 70 website on my Raq4,

    There are trouble in 1 domain (zzzzz.com) about receiving email : Reject by server!

    I try to send to [email protected] but fail always

    I have return email like below :

    ----- Transcript of session follows -----
    ... while talking to zzzzz.com.:
    >>> MAIL From:<[email protected]> SIZE=1486
    <<< 553 5.3.0 <[email protected]>... No such user here
    501 5.6.0 <[email protected]>... Data format error

    What must I do?

  2. #2
    This is a DNS issue:

    Whats your MX records for that site, it should be:

    zzzzz.com pointing to mail.zzzzz.com
    zzzzz.com pointing to zzzzz.com

    Also, you might as well check the A and PTR records.

    Looks like your domain is not resolving.

    Regards,

    Al-Juhani

  3. #3
    Join Date
    May 2002
    Location
    London UK redbus
    Posts
    74
    Nope. in fact its User Unknowen. means there is not a email account for that site with that alis

    Originally posted by aljuhani
    This is a DNS issue:

    Whats your MX records for that site, it should be:

    zzzzz.com pointing to mail.zzzzz.com
    zzzzz.com pointing to zzzzz.com

    Also, you might as well check the A and PTR records.

    Looks like your domain is not resolving.

    Regards,

    Al-Juhani

  4. #4
    The error message says it exactly that the problem is related to MX record..

    it says "... while talking to zzzzz.com.: " while it should be talking the mail server.

    on RAQ4, you need to have two MX records:

    domain.com --------------> mail.domain.com
    domain.com --------------> domain.com

    Regards,

    Al-Juhani

  5. #5
    Join Date
    Jan 2001
    Location
    the Netherlands
    Posts
    542
    You only need one MX record.

    I know this error. I got the same problem when i migrated the main domein from one raq to another located in another network.
    Eversince that domain cannot send email to the one it used to live on.

    Sorry to say that i still haven't located the source of this problem, although it looks DNS related nothing i tried with DNS records helped.

  6. #6
    Join Date
    May 2001
    Location
    .
    Posts
    192
    Originally posted by dutchie
    You only need one MX record.

    I know this error. I got the same problem when i migrated the main domein from one raq to another located in another network.
    Eversince that domain cannot send email to the one it used to live on.

    Sorry to say that i still haven't located the source of this problem, although it looks DNS related nothing i tried with DNS records helped.
    Which must be set on MX records?

    domain.com --------------> mail.domain.com
    domain.com --------------> domain.com
    domain.com --------------> www.domain.com

    or all above?

  7. #7
    Join Date
    Aug 2001
    Location
    Atlanta
    Posts
    1,167
    In this example, which is not the 'official' way of doing things but the method I use as well, you would need a single MX record for mail.domain.com

    Make sure your mail server alias field in the GUI is set to domain.com, mail.domain.com

    Brandon

  8. #8
    Ok the DNS setup :

    1. Add "A" Record, Do NOT ENTER ANYTHING IN host, Enter domain.com, Enter IP address. Choose Reverse Mapping.

    2. Add "A" Record, Host Name www, domain name domain.com, enter IP address, Do not select reverse Mapping.

    3. Add "A" Record, Host Name ftp, domain name domain.com, enter IP address, Do not select reverse Mapping.

    4. Add "A" Record, Host Name MAIL, domain name domain.com, enter IP address, Do not select reverse Mapping.

    5. Click on Start of Authority (SOA) and change the primary and secondary server to your name servers ns1.yourserver.com, ns2.yourserver.com.
    [B]

    6. Add "MX" record:

    Leave hostname blank.
    in the domain box Enter Domain.com
    in the mail server Enter mail.domain.com

    7. Add another "MX" record:

    Leave hostname blank.
    in the domain box Enter Domain.com
    in the mail server Enter Domain.com

    8. When all records are done click " SAVE CHANGES TO DNS SERVER" then on the Next screen (main control panel screen) also click save the changes.

    Note:

    A Record Points to an IP address
    MX Record Points to a name. It is important that MX record to point to a name which has a corresponding "A" record that points to the site IP Address.

    when you creat the virtual site, and under site settings enter for Email Server Aliases: domain.com, mail.domain.com ..

    Regards,

    Al-Juhani

  9. #9
    Join Date
    Aug 2001
    Location
    Atlanta
    Posts
    1,167
    1. Add "A" Record, Do NOT ENTER ANYTHING IN host, Enter domain.com, Enter IP address. Choose Reverse Mapping.
    You should only select reverse mapping (which generates a PTR) if (a) this is a unique IP only for this site, or (b) it's the IP for the main site on the RaQ. Otherwise, it's a wasted effort and will allow anyone who digs your DNS to easily determine every site that your DNS serves.

    5. Click on Start of Authority (SOA) and change the primary and secondary server to your name servers ns1.yourserver.com, ns2.yourserver.com.
    Why is this necessary?

    7. Add another "MX" record:
    This is definitely *not* necessary.

    Balance looks good.

    Brandon

  10. #10
    Join Date
    Sep 2001
    Posts
    238
    Just a question about DNS management that seems to be a standard:

    WHY is it that everyone makes mail and/or ftp subdomain entries in the DNS?

    Personally, my domains don't have or use them. And mail in particular works better for them without them. Less confusing.
    That, and the FTP and Pop connections could care less if you are connecting to ftp.domain.com, www.domain.com, domain.com, mail.domain.com, pop.domain.com, <ip>, or even <any sub>.mainserverdomain.com. As long as you talk to the server.

    Which is why I wonder WHY ON EARTH PEOPLE SET UP USELESS MAIL AND FTP SUBDOMAINS.

    Sorry, this has just been bugging me for about 2 years now........

  11. #11
    Actually I do not use the ftp.domain.com, I prefer to use the site IP address so I do not creat an "A" record for that. For mail you can use whatever in the "A" record such as myperonalpop3email.domain.com but still you have to make the MX record points to that name.

    Anyway, these things are called Standards likes US PSI (Pounds per square inch for pressure) and the rest of the world metric (bar for pressure). I do not want to confuse the person who is asking the question. Just make it simple.

    and cbtrussell:

    You need that MX record (Domain pointing to domain), if you do not have it you will not be able to send email.

    Al-Juhani

  12. #12
    Join Date
    Aug 2001
    Location
    Atlanta
    Posts
    1,167
    You need that MX record (Domain pointing to domain), if you do not have it you will not be able to send email.
    Sorry to disagree, but that is absolutely false. You can use mail.domain.com, or domain.com, or even www.domain.com as the manual suggests, but mail will work quite well with just one.

    Brandon

  13. #13
    If you check the note of my oprevious post today, you will see that there is no real disagreement between us over this MX issue. OK here is it again:

    A Record Points to an IP address
    MX Record Points to a name. It is important that MX record to point to a name which has a corresponding "A" record that points to the site IP Address.

    Now when we have an MX record domain.com pointing to domain.com, the domain.com should have an A record that points to the site IP address OK. Since the Domain.com and also www.domain.com points to the same IP address i.e resolving to the same IP, there is no need to have an MX record to www.domain.com. Example, if you enter domain.com in the browser it forward you to www.domain.com so it is the same mail man why have more than two enteries in the MX table.

    Also, if you have only an MX record pointing to www.domain.com, you will need to have your email format user@www.domain.com! If you send a message to a user on that site [email protected] it will bounce.

    Al-Juhani

  14. #14
    Join Date
    Jan 2001
    Location
    the Netherlands
    Posts
    542

  15. #15
    Join Date
    Aug 2001
    Location
    Atlanta
    Posts
    1,167
    Hi aljuhani,

    By all means, whatever you want to do is fine with me. No problems here.

    But for the purposes of the thread and the archives, in the event that someone is actually reading this in an attempt to get their mail working right, I want to be clear:

    Fact: You only need one MX record. Either do it exactly as the RaQ manual suggests, or use my method below, both will work:

    A record: domain.com > IP

    A record: www.domain.com > IP

    A record: mail.domain.com > IP

    MX: domain.com served by high priority mail server mail.domain.com

    save changes all the way out including the main control panel

    In site settings for the domain, in the mail server alias field, put
    domain.com, mail.domain.com

    (*that* is why you don't need two MX records, aljuhani)

    tell your users to point their mail clients at mail.domain.com

    voila', mail.

    HTH,

    Brandon

  16. #16
    Join Date
    Jan 2001
    Location
    the Netherlands
    Posts
    542
    Fact: You only need one MX record. Either do it exactly as the RaQ manual suggests, or use my method below, both will work:
    So will all the other systems mentioned above.
    But:
    "my" system uses one less DNS record and you need to enter only one domain in the mail server alias field.

    I think it is important to keep things as simple as possible to avoid mistakes.
    My controlpanel entries looks like:

    www
    domain.com
    domain.com
    domain.com

    Point is, none of all this will solve the error Giza gets.
    His DNS works for 69 domains. Now what the heck is wrong with number 70?

  17. #17
    I have the same issue, I think I'm configured pretty much exactly as indicated above, but when I try sending from either [email protected] or [email protected] I get the same error...

    ----- The following addresses had permanent fatal errors ----- <[email protected]>
    (reason: 553 <[email protected]>... No such user here)

    ----- Transcript of session follows -----
    ... while talking to mail.receiver.net.:
    >>> MAIL From:<[email protected]> SIZE=3485
    <<< 553 <[email protected]>... No such user here
    501 5.6.0 <[email protected]>... Data format error

    If I use the alias (usera) instead of domusera, the same error occurs, just with usera instead of domusera.

    my DNS records:
    domain.com -> A -> IP
    mail.domain.com -> A -> IP
    ns1.domain.com -> A -> IP
    ns2.domain.com -> A -> IP2
    www.domain.com -> A -> IP
    domain.com mail is sent to high priority mail server mail.domain.com

    in the RAQ control panel for the site (it's the primary site on the server),
    host is ns1
    domain is domain.com
    web aliases are domain.com www.domain.com
    e-mail aliases are domain.com, mail.domain.com, www.domain.com

    usernames are:
    domusera, with alias usera
    domuserb, with alias userb

    virtusertable has the entries:
    [email protected] domusera
    [email protected] domuserb
    [email protected] domusera
    [email protected] domuserb

    #accept at domains:
    @mail.domain.com [email protected]
    @www.domain.com [email protected]
    @domain.com [email protected]

    There... I think I covered everything.

    --Will

  18. #18
    Anyone find a fix for this?

    One person i know has this same issue, this is when SENDING mail he gets a BOUNCE back.


    ----- The following addresses had permanent fatal errors -----
    <[email protected]>
    (reason: 553 5.3.0 <[email protected]>... No such user here)

    ----- Transcript of session follows -----
    ... while talking to MYMAILHOST.:
    >>> MAIL From:<[email protected]> SIZE=1146
    <<< 553 5.3.0 <[email protected]>... No such user here
    501 5.6.0 Data format error


    The thing that confuses me here is that is that the sender's email address apears to be the name getting rejected with the no such user here ([email protected]) instead of the address he is sending to which is [email protected].

    Any ideas?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •