hosted by liquidweb


Go Back   Web Hosting Talk : Advertising Forums : Employment Offers & Requests : Systems Management Requests : Need help with SSH on Centos 5 x64
Reply

Forum Jump

Need help with SSH on Centos 5 x64

Reply Post New Thread In Systems Management Requests Subscription
 
Send news tip View All Posts Thread Tools Search this Thread Display Modes
  #1  
Old 05-27-2007, 10:05 PM
Coolraul Coolraul is online now
Community Liaison
 
Join Date: May 2004
Location: Toronto, Canada
Posts: 4,915

Need help with SSH on Centos 5 x64


I have been struggling with a couple of new servers that we want to run Centos 5 on. For a second assume that is our desire so going back to 4.x isn't an option yet.

Now while I mention Centos 5, the problem seems to be with PAM and x64.

When trying to login to the server via ssh, the login succeds but then immediately kicks the user out. I have tried this with root and another user created. I have set the UsePam option to no to try to resolve this in sshd_config.

On the H-Sphere forum I found this reference:

http://www.forum.psoft.net/showthread.php?t=19212

" if i try to connect with ssh and i enter the right password i get an error and ssh closes the connection
The answer already was in the ticket you opened:
Quote:
That is known bug dealt with PAM authentication.
The bug was fixed for i386 systems long time ago. But it was not fixed for x86_64 architecture.

We build FreeVPS kernel new version 1.5-13.1 for x86_64 architecture to fix the problem.
We also installed the kernel into the box IP 64.71.227.16.

Please reboot the box with the new FreeVPS kernel version: 2.6.9-freevps-1.5-13.1smp.
Let us know the result."

At this point I am willing to pay to have someone look into this. Whatever is done on the first server will need to be replicated to 2 more so I am looking to pay someone to fix it via IPKVM on all 3.

Please PM me. Nothing is on these servers so I am happy to give you access to fix or if you know how to fix it and point me in the right direction I can or one of our techs can fix it and I am still willing to pay.

__________________
Can't we all just get along

Reply With Quote

Notice to Consumers
Thread Summary Please be aware that every offer has limits beyond what is displayed in the thread. You should visit the site advertising and read any Terms of Service or Acceptable Use Policy they have in place. If you can't find answers on how they measure what you're purchasing, ask. If the offer or request doesn't regard some type of hosting, you still need to research beyond what’s printed in the ad.
  • Research any provider to know what limits are in place, especially with any offer concerning disk space and/or bandwidth. These are generally defined in the TOS or AUP.
  • Read provider reviews. If you find no reviews, create a thread and ask for others' first-hand experience with the provider.
  • If you're unsure on the exact details of an offer - ask. Simply respond to this thread and ask the provider for clarification.

Sponsored Links
  #2  
Old 05-27-2007, 10:55 PM
ServerNinja ServerNinja is offline
LORD OF THE RINGS
 
Join Date: Dec 2005
Location: Internet
Posts: 1,317
Have you compared the file /etc/pam.d/login in this server with any of the server thats working fine?

__________________
Senior Server Administrator with 8 years experience for hire(Full Time). Please contact me (ssapache71@gmail.com) if you are interested!

Reply With Quote
  #3  
Old 05-28-2007, 02:38 PM
Coolraul Coolraul is online now
Community Liaison
 
Join Date: May 2004
Location: Toronto, Canada
Posts: 4,915
This is the only one with this combination. I have 3 Centos 5 x_64 servers all with this same issue.

__________________
Can't we all just get along

Reply With Quote
Sponsored Links
  #4  
Old 05-28-2007, 04:56 PM
Coolraul Coolraul is online now
Community Liaison
 
Join Date: May 2004
Location: Toronto, Canada
Posts: 4,915
We had a company www.techbrein.com resolve this for us. He worked fast and kept me updated the entire way.

__________________
Can't we all just get along

Reply With Quote
  #5  
Old 05-30-2008, 08:43 PM
ktizo ktizo is offline
New Member
 
Join Date: Jul 2005
Posts: 0
have you solved this problem, seems that my Centos5 64bit is having similar problems. Can anyone shed some light to this?

Reply With Quote
Reply

Related posts from TheWhir.com
Title Type Date Posted
Red Hat Takes Active Role in CentOS Project to Drive New Technology Adoption Web Hosting News 2014-01-08 12:00:22
Solar VPS Becomes Official Mirror for Centos and Ubuntu Web Hosting News 2013-04-16 11:03:34
Inerol Solutions Launches XEN VPS Hosting Service Web Hosting News 2014-05-23 15:46:53
Web Hosting Sales and Promos Roundup – March 22, 2013 Web Hosting News 2014-05-23 15:43:14
Web Host Rackspace Adds FreeBSD 9, CentOS 6.3 Support to Cloud Servers Web Hosting News 2012-07-30 12:47:10


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump
Login:
Log in with your username and password
Username:
Password:



Forgot Password?
Advertisement:
Web Hosting News:



 

X

Welcome to WebHostingTalk.com

Create your username to jump into the discussion!

WebHostingTalk.com is the largest, most influentual web hosting community on the Internet. Join us by filling in the form below.


(4 digit year)

Already a member?