Results 1 to 4 of 4
  1. #1

    Disable Open Relay?

    how do i configure the mail server (CPanel/Exim) to not accept mail from unauthorize users? SMTP seems to be accept mail from anyone who knows the existence of this server... how do i make the server to request the user to login before the user can send mail through the mail server? thanks.

  2. #2
    Join Date
    Mar 2002

    Check the relaying,smtp and verification sections.

  3. #3
    Join Date
    Jun 2002
    cpanel actually has a built in process that dovetails with Exim to prevent this, or should.....
    "antirelayd" keeps unauthorized users from relaying through the smtp server in question- and adds authenticated pop3 users to the allowed relay hosts file. However, users can also authenticate to exim for relaying directly with a valid mailbox UID and password.

    take a look at /scripts/fixrelayd and see if all is well to make sure your relaying protection is working.

  4. #4

    enable authorization

    add this line to your /etc/exim.conf file

    auth_hosts = *

    make sure you add that line before the host_accept_relay line

    restart exim(mailserver) from WHM

    now, all the mails sent using your server's smtp will need to authrize first with user/pass and it will allow only those users whose email address exists on local server.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts