Results 1 to 5 of 5
  1. #1

    Server Load High

    server load is too high, can you suggest why too many process of qmail-smtpd even i stopped qmail and there is no more 25 emails in queue.

    top - 22:26:03 up 8 days, 5:56, 0 users, load average: 150.96, 150.27, 142.68
    Tasks: 183 total, 150 running, 33 sleeping, 0 stopped, 0 zombie
    Cpu(s): 99.0% us, 1.0% sy, 0.0% ni, 0.0% id, 0.0% wa, 0.0% hi, 0.0% si
    Mem: 4167500k total, 146416k used, 4021084k free, 0k buffers
    Swap: 0k total, 0k used, 0k free, 0k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    20168 qmaild 25 0 3468 1432 1168 R 3.3 0.0 2:55.27 qmail-smtpd
    20208 qmaild 25 0 3468 1432 1168 R 3.3 0.0 2:43.98 qmail-smtpd
    20320 qmaild 25 0 3468 1432 1168 R 3.3 0.0 2:38.56 qmail-smtpd
    20425 qmaild 25 0 3468 1432 1168 R 3.3 0.0 2:31.09 qmail-smtpd
    20444 qmaild 25 0 3468 1432 1168 R 3.3 0.0 2:27.97 qmail-smtpd
    5413 qmaild 25 0 3468 1432 1168 R 3.3 0.0 1:00.38 qmail-smtpd
    5705 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:57.91 qmail-smtpd
    5763 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:57.40 qmail-smtpd
    5806 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:56.99 qmail-smtpd
    5999 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:55.98 qmail-smtpd
    7318 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:53.39 qmail-smtpd
    7639 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:51.43 qmail-smtpd
    7866 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:50.29 qmail-smtpd
    7980 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:49.59 qmail-smtpd
    8023 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:49.29 qmail-smtpd
    8101 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:48.48 qmail-smtpd
    9253 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:47.40 qmail-smtpd
    9355 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:46.78 qmail-smtpd
    9386 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:46.48 qmail-smtpd
    9525 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:45.84 qmail-smtpd
    9611 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:45.81 qmail-smtpd
    9854 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:44.89 qmail-smtpd
    9974 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:44.08 qmail-smtpd
    11272 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:42.29 qmail-smtpd
    11331 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:42.09 qmail-smtpd
    11482 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:41.69 qmail-smtpd
    11652 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:40.99 qmail-smtpd
    12040 qmaild 25 0 3468 1432 1168 R 3.3 0.0 0:39.41 qmail-smtpd
    3530 qmaild 25 0 3468 1432 1168 R 3.0 0.0 1:08.48 qmail-smtpd
    12246 qmaild 25 0 3468 1432 1168 R 2.0 0.0 0:38.79 qmail-smtpd

  2. #2
    Join Date
    Mar 2002
    Location
    St. Louis, MO
    Posts
    1,377
    tail -f the logs and watch it ti see what its actually doing

  3. #3
    Join Date
    Apr 2003
    Location
    Los Angeles, CA
    Posts
    785
    qmail-smtpd is the SMTP receive daemon. You are being flooded with too many incoming connections. If you are using tcpserver from daemontools, there is a command line option -c to limit concurrent connections. Set it to 50 or so (depending on your resources) and restart it.
    Pings <1 ms, Unlimited Transfer, Lowest Price: http://localhost/

  4. #4
    Check to see who is using the most CPU usage:

    Code:
    ps auxc | awk '{print $3" "$1" "$11" pid:: "$2}' | sort -rn  | head -n 5
    Also look at memory usage:

    Code:
    ps auxc | sort -n --key=5 |  tail -n 7  | awk '{print $4" "$5" "$11}'

  5. #5
    Join Date
    Apr 2004
    Location
    Singapore
    Posts
    617
    Look like qmail-smtpd is causing the problem. Limit the usage of incoming smtp connection.

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •