Results 1 to 3 of 3
  1. #1

    ImageMagick new ver install

    Hello, i have installed imagemagick via WHM, it installed version 4.*** but i need version 5.2.** to get a script working.

    I tried to un-install imagemagick version 4.** with rpm -e but it says it can't find it, but rpm -qi says it is installed.

    WHM may have installed it from src.rpm would i have to specify .src.rpm to un-install?

    I DL the correct 5.*** version for RH 6.2, i needed to install truetype and bzip2 to get it working. Truetype went ok but i get errors with bzip2.

    why do i need bzip2, well i get this error when trying to install new version 5 of imagemagick:
    [email protected] [/tmp/install]# rpm -Uvh ImageMagick-5.4.5-1.i386.rpm
    error: failed dependencies: is needed by ImageMagick-5.4.5-1

    I tried to install new version bzip2-1.0.0-1.i386.rpm downloaded from ImageMagick ftp mirror, this file was in same dir as Imagemagick ver 5.*** so assume it to be correct one, but following errors

    [email protected] [/tmp/install]# rpm -Uvh bzip2-1.0.0-1.i386.rpm
    error: failed dependencies: is needed by passwd-0.64.1-1 is needed by rpm-4.0.2-6x is needed by rpm-build-4.0.2-6x is needed by ucd-snmp-4.2.3-1.6.x.3 is needed by ucd-snmp-utils-4.2.3-1.6.x.3 is needed by ImageMagick-4.2.9-3

    rpm -qi bzip reports
    Name : bzip2 Relocations: /usr
    Version : 0.9.5d Vendor: Red Hat, Inc.
    Release : 2 Build Date: Mon 07 Feb 2000 08:57:59 PM GMT
    Install date: Fri 18 May 2001 08:53:51 AM BST Build Host:
    Group : Applications/File Source RPM: bzip2-0.9.5d-2.src.rpm

    would building imagemagick/bzip2 from source cure bzip2 problems?

  2. #2
    Join Date
    Mar 2002
    Do everything from source. Much easier. RPMs just cause more trouble with the dependency system they got.

  3. #3
    thanks for reply, yes i ended doing it from source.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts