Results 1 to 5 of 5
  1. #1

    Install PDO_MYSQL

    I installed PDO_MYSQL in my server, and in the end of the installation, appeared the following message:

    Build process completed successfully
    Installing ' /var/tmp/pear-build-root/install-PDO_MYSQL-1.0.2//usr/local/lib/php/extensions/no-debug-non-zts-20050922/pdo_mysql.so '
    install ok: channel://pecl.php.net/PDO_MYSQL-1.0.2
    You should add " extension=pdo.so " to php.ini
    You should add " extension=pdo_mysql.so " to php.ini

    I added in the php.ini "extension=pdo.so" and "extension=pdo_mysql.so". But when I access in my site phpinfo.php, it doesn't list that the pdo_mysql is installed, just list:

    PDO
    PDO SUPPORT ENABLED
    PDO DRIVERS SQLITE2

    Somebody would know how to do so that appears in the php.ini? because for the that I saw, it is installed.

    Thanks

  2. #2
    do pdo.so and pdo_mysql.so exist in your /usr/lib directory?

    Code:
    updatedb
    locate pdo.so
    locate pdo_mysql.so

  3. #3
    Hi FirmbIT,


    [email protected] [/]# locate pdo.so
    /usr/local/lib/php/extensions/no-debug-non-zts-20050922/pdo.so

    [email protected] [/]# locate pdo_mysql.so
    /usr/local/lib/php/extensions/no-debug-non-zts-20050922/pdo_mysql.so

  4. #4
    Try adding this to your php.ini

    extension=/usr/local/lib/php/extensions/no-debug-non-zts-20050922/pdo.so
    extension=/usr/local/lib/php/extensions/no-debug-non-zts-20050922/pdo_mysql.so

    /etc/init.d/httpd restart

  5. #5
    Yes FirmbIT,

    Its works now

    Thanks!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •