Results 1 to 11 of 11
  1. #1
    Join Date
    Apr 2004
    Posts
    80

    Question DNS/MX/Zone File Problems

    Hi

    I`m a newby to dedicated servers so go easy with me please

    When I view my servers hostname on dnsreport I get the following errors:

    WARN

    MX records are not CNAMEs

    WARNING: When I looked up your MX record, your DNS server returned a CNAME. This is an unusual situation, and I can't handle it -- the following MX tests may not work properly. The problem is:
    mail.fishsense.co.uk.->fishsense.co.uk.
    FAIL

    MX A lookups have no CNAMEs

    WARNING: One or more of your MX records points to a CNAME. CNAMEs are prohibited in MX records, according to RFC974, RFC1034 3.6.2, RFC1912 2.4, and RFC2181 10.3. The problem MX record(s) are:
    mail.fishsense.co.uk.->fishsense.co.uk.->67.18.217.170

    WARN
    Mail server host name in greeting

    WARNING: One or more of your mailservers is claiming to be a host other than what it really is (the SMTP greeting should be a 3-digit code, followed by a space or a dash, then the host name). If your mailserver sends out E-mail using this domain in its EHLO or HELO, your E-mail might get blocked by anti-spam software. This is also a technical violation of RFC821 4.3 (and RFC2821 4.3.1). Note that the hostname given in the SMTP greeting should have an A record pointing back to the same server. Note that this one test may use a cached DNS record.

    fishsense.co.uk claims to be non-existent host server.fishsense.co.uk:
    220-server.fishsense.co.uk ESMTP Exim 4.63 #1 Fri, 12 Jan 2007 08:10:24 +0000 220-We do not authorize the use of this system to transport unsolicited, 220 and/or bulk e-mail.

    The contents of the zone file are:


    Code:
    ; Zone File for fishsense.co.uk
    $TTL 14400
    @       86400   IN      SOA     ns1.fishsense.co.uk.    myemail.domain.com       (
                                            2007011204
                                            7200
                                            7200
                                            2417200
                                            86400
                                            )
    
    fishsense.co.uk.        86400   IN      NS      ns1.fishsense.co.uk.
    fishsense.co.uk.        86400   IN      NS      ns2.fishsense.co.uk.
    
    
    fishsense.co.uk.        14400   IN      A       67.18.217.170
    
    localhost.fishsense.co.uk.      14400   IN      A       127.0.0.1
    
    fishsense.co.uk.           14400   IN      MX      0       mail.fishsense.co.uk.
    ns1.fishsense.co.uk.    14400   IN      A       67.18.217.170
    ns2.fishsense.co.uk.    14400   IN      A       67.18.217.171
    fishsense.co.uk.           14400   IN      TXT     "v=spf1 a mx ~all"
    www     14400       IN         CNAME   fishsense.co.uk.
    mail       14400       IN         CNAME   fishsense.co.uk.
    ftp         14400       IN         A            67.18.217.170
    server.fishsense.co.uk  14400   IN      A       67.18.217.170

    Can someone explain to me in laymans terms (aka as simple as possible) on how I can fix the above errors.

    Thanks

  2. #2
    maybe somehting like this? this is a hit before zzz-ing, so forgive me if i make mistakes.


    $TTL 14400
    @ 86400 IN SOA ns1.fishsense.co.uk. hostmaster.fishsense.co.uk. (
    2007011204
    7200
    7200
    2417200
    86400
    )

    IN NS ns1.fishsense.co.uk.
    IN NS ns2.fishsense.co.uk.
    IN TXT "v=spf1 mx -all"
    IN MX 10 mail.fishsense.co.uk.
    IN A 67.18.217.170

    localhost 14400 IN A 127.0.0.1
    ns1 14400 IN A 67.18.217.170
    ns2 14400 IN A 67.18.217.171
    www 14400 IN A 67.18.217.170
    mail 14400 IN A 67.18.217.170
    ftp 14400 IN A 67.18.217.170
    server 14400 IN A 67.18.217.170

  3. #3
    Join Date
    Oct 2002
    Location
    State of Disbelief
    Posts
    22,951
    "fishsense.co.uk. 14400 IN MX 0 mail.fishsense.co.uk."
    The problem is the "mail" in front of it. It should be:
    "fishsense.co.uk. 14400 IN MX 0 fishsense.co.uk."

    "fishsense.co.uk claims to be non-existent host server.fishsense.co.uk"
    You don't have rDNS set up for the server host name. Ask your provider to map the IP to your hostname (rDNS).
    Last edited by bear; 01-12-2007 at 08:32 AM.

  4. #4
    Join Date
    Apr 2004
    Posts
    80
    Thanks thats removed the error.

    but I`m now getting this error when I attempt to sent mail thats in the mail queue

    Message 1H5IAb-0001Wx-0m is no longer frozen
    LOG: MAIN
    cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1H5IAb-0001Wx-0m
    delivering 1H5IAb-0001Wx-0m
    LOG: MAIN
    ** [email protected] <[email protected]> R=fail_remote_domains: unrouteable mail domain "domain.com"
    LOG: MAIN
    Frozen (delivery error message)
    If I try to deliver individually I get this:

    1H5FCy-0001pZ-1C-H
    mailnull 47 12
    <>
    1168580648 0
    -ident mailnull
    -received_protocol local
    -body_linecount 148
    -allow_unqualified_recipient
    -allow_unqualified_sender
    -frozen 1168621988
    -localerror
    -manual_thaw
    XX
    1
    [email protected]

    160P Received: from mailnull by server.fishsense.co.uk with local (Exim 4.63)
    id 1H5FCy-0001pZ-1C
    for [email protected]; Fri, 12 Jan 2007 05:44:08 +0000
    048 X-Failed-Recipients: [email protected]
    029 Auto-Submitted: auto-replied
    066F From: Mail Delivery System <[email protected]>
    032T To: [email protected]
    059 Subject: Mail delivery failed: returning message to sender
    055I Message-Id: <[email protected]>
    038 Date: Fri, 12 Jan 2007 05:44:08 +0000

    1H5FCy-0001pZ-1C-D
    This message was created automatically by mail delivery software.

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    [email protected]
    (generated from [email protected])
    unrouteable mail domain "mydomain.com"

    ------ This is a copy of the message, including all the headers. ------

    Return-path: <[email protected]>
    Received: from root by server.fishsense.co.uk with local (Exim 4.63)
    (envelope-from <[email protected]>)
    id 1H5FBt-0001dO-Q2
    for [email protected]; Fri, 12 Jan 2007 05:44:07 +0000
    From: [email protected] (Cron Daemon)
    To: [email protected]
    Subject: Cron <[email protected]> /scripts/upcp
    X-Cron-Env: <SHELL=/bin/sh>
    X-Cron-Env: <HOME=/root>
    X-Cron-Env: <PATH=/usr/bin:/bin>
    X-Cron-Env: <LOGNAME=root>
    X-Cron-Env: <USER=root>
    Message-Id: <[email protected]>
    Date: Fri, 12 Jan 2007 05:44:03 +0000

  5. #5
    Join Date
    Dec 2005
    Location
    Internet
    Posts
    1,337
    1) Check whether the entry of that domain is in /etc/localdomains (if its MX entry is pointing to the same server. Otherwise, remove its entry from /etc/localdomains and add it in /etc/remotedomains)

    2) If the above things are correct, check for the file /etc/eximmailtrap , if so remove it and check the same again.

    Let us know how it goes.

  6. #6
    Join Date
    Apr 2004
    Posts
    80
    This is the contents of /etc/localdomains

    Code:
    affiliate-tips.co.uk
    all-rs.co.uk
    askanglers.co.uk
    autosportnews.co.uk
    bayeswaterfishing.co.uk
    bivvies.co.uk
    fishsense.co.uk
    nesa.co.uk
    northwestcarp.co.uk
    server.fishsense.co.uk
    tourofmull.co.uk
    vivvo.co.uk
    www.sea-angler.org
    /etc/remotedomains doesn't exist


    I looked in the /var/log/exim_mainlog and it has this

    Code:
    2007-01-12 18:58:36 End queue run: pid=29825
    2007-01-12 18:58:40 cwd=/usr/local/cpanel/whostmgr/docroot 3 args: /usr/sbin/exim -Mvh 1H5FCy-0001pZ-1C
    2007-01-12 18:58:40 cwd=/usr/local/cpanel/whostmgr/docroot 3 args: /usr/sbin/exim -Mvb 1H5FCy-0001pZ-1C
    2007-01-12 18:58:43 cwd=/usr/local/cpanel/whostmgr/docroot 3 args: /usr/sbin/exim -Mt 1H5FCy-0001pZ-1C
    2007-01-12 18:58:43 1H5FCy-0001pZ-1C unfrozen by root
    2007-01-12 18:58:43 cwd=/usr/local/cpanel/whostmgr/docroot 4 args: /usr/sbin/exim -v -M 1H5FCy-0001pZ-1C
    2007-01-12 18:58:43 1H5FCy-0001pZ-1C ** [email protected] <[email protected]> R=fail_remote_domains: unrouteable mail domain "mydomain.com"
    2007-01-12 18:58:43 1H5FCy-0001pZ-1C Frozen (delivery error message)

  7. #7
    Join Date
    Dec 2005
    Location
    Internet
    Posts
    1,337
    Please check "mydomain.com" (Assuming you are aliased the domainname) is present on /etc/localdomains. As mentioned before, if the MX entry of the domain is pointing to the same server, the entry of the domain have to be there.

    Also, check /etc/eximmailtrap exists. If so, remove it and try the same.

  8. #8
    Join Date
    Apr 2004
    Posts
    80
    the "mydomain.com" is there (fishsense.co.uk)

    /etc/eximmailtrap doesn`t exist

  9. #9
    Join Date
    Oct 2002
    Location
    State of Disbelief
    Posts
    22,951
    "unrouteable mail domain "mydomain.com""

    Have you set up your resolvers in WHM properly? This is needed to lookup names...

  10. #10
    Join Date
    Apr 2004
    Posts
    80
    Quote Originally Posted by bear
    "unrouteable mail domain "mydomain.com""

    Have you set up your resolvers in WHM properly? This is needed to lookup names...
    Ahh that was the problem

    Thanks to all that helped

    This topic can be closed now
    Last edited by CheaperHost1; 01-12-2007 at 04:44 PM.

  11. #11
    Join Date
    Jun 2006
    Posts
    54
    Quote Originally Posted by bear
    "unrouteable mail domain "mydomain.com""

    Have you set up your resolvers in WHM properly? This is needed to lookup names...
    mine are setup properly, but I'm still seing this problem

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •