Results 1 to 3 of 3
  1. #1
    Join Date
    Apr 2002

    Weird DNS problem

    On one of our servers it appears that the DNS information is not reloading. I have updated the serial number for a particular zone file and doing a:

    dig @localhost SOA

    does not report and updated SOA.

    When I do a /usr/sbin/ndc reload, I get the follow message in /var/log/messages:

    Jun 26 21:13:32 host1 named[22890]: reloading nameserver
    Jun 26 21:13:32 host1 named[22890]: couldn't create pid file '/var/run/'
    Jun 26 21:13:32 host1 named[22890]: Forwarding source address is [].3636
    Jun 26 21:13:32 host1 named[22890]: Ready to answer queries.

    When I reload BIND in the WHM, I get:

    stdin: is not a tty
    ndc: error: ctl_client: evConnect(fd 3): Connection refused
    ndc: error: cannot connect to command channel (/var/run/ndc)
    Attempting to restart bind

    bind status
    bind did not return a status report
    bind started ok

    I'm not real technical savy when it comes to DNS problems, any help would be appreciated.


  2. #2
    Join Date
    Apr 2001
    Depok, Indonesia
    I suspect you are trying to restart bind as a normal user. Try doing the same thing as root user.

  3. #3
    Join Date
    Apr 2002
    I forgot to post on here last night. I found the problem, with the SOA not updating... I was editting the wrong zone file. For some reason there were two entries and one had capital letters, and that was the one I was changing, but named.conf pointed to the lowercase one.

    As for the error, I made some modifications to /var/run and it appears to be working now.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts