Results 1 to 3 of 3
  1. #1
    Join Date
    May 2006
    Posts
    66

    Server crashing, help please!

    This is weird, my server would sometime run great for 1-2 days then suddenly crash. Once the server start crashing it would then start chain crashing. I really have no idea why.

    This time I notice some entry within the /var/log/messages, I hope someone can guide me in the right direction.

    kernel: Debug: sleeping function called from invalid ontext at include/linux/rwsem.h:43
    kernel: in_atomic():0[expected: 0], irqs_disabled():1
    kernel:
    kernel: Call Trace:<ffffffff80132c79>{__might_sleep+173} <ffffffff8013897d>{profile_task_exit+33}
    kernel: <ffffffff80139bc6>{do_exit+34} <ffffffff80117e88>{do_machine_check+841}
    kernel: <ffffffff8011147f>{machine_check+127} <EOE>

    Today my server crash only after 5 hours. There is no error on bootup, or at least I do not beleive so.

    This is the only thing that may look like an error during bootup:
    Warning: acpi_table_parse(ACPI_SLIT) returned 0!
    kernel: No mptable found.
    kernel: Aperture from northbridge cpu 0 too small (32 MB)
    kernel: Your BIOS doesn't leave a aperture memory hole
    kernel: Please enable the IOMMU option in the BIOS setup

    I don't think the above could cause the problem, but I am not positive.

    Any help would be great. Thank you.

  2. #2
    Join Date
    Mar 2006
    Location
    New York USA
    Posts
    402
    You should look at the *nix distro creators website. Submit to them the errors you posted here, they will have a better idea of what is going on. Also state any changes you made just prior to this error taking place.

  3. #3
    Have you trued your kernal damage to them as they sometimes couse trouble and do you have webmin installed as that frommy exsperience couses ploblems

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •