Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2003
    Posts
    180

    Few questions in SSH and server

    1. Why doesn't my server recognize special characters? For example in a webpage the text copyright shows as ? copyright when accessed in a internet browser.

    2. How to execute and restore a mysql database in SSH? I want to execute a file called backup.sql using custom username/password for the database.

    I have a CentOS Linux 4.3 w/ Webmin 1.310.

  2. #2
    It sounds like more of a browser issue than a server issue, but canr be for sure. Try it in both Mozilla and IE. If same result, it may be server issue and check httpd config for a setting in there.

    For restoring databases, i would use phpmyadmin.

  3. #3
    Join Date
    Dec 2002
    Location
    chica go go
    Posts
    11,858
    First issue is a result of your web browser. Try typing © instead of pasting right off the character map.

    Phpmyadmin doesn't work well with large database backups. upload backup.sql via ftp, and ise this command to restore the backup:

    mysql -u username -p databasename < backup.sql
    <enter password>

    Then it'll restore. For larger backups, it will take a longer time. Whatever you do, don't exit while the program is running. It'll screw up your database, and it may take a long time to empty out all the old data.

  4. #4
    Join Date
    Jul 2003
    Posts
    180
    Thanks for the help. This worked great!

  5. #5
    Join Date
    Jul 2003
    Posts
    180
    Just for future people who may have the same problem, to fix the wrong character set codes, all you need to do is change this in the httpd.conf file:

    AddDefaultCharset <code>

    i.e.

    AddDefaultCharset ISO-8859-1

    This can also be fixed (I believe) by putting meta tags on the header of your webpage:

    Code:
    <meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •