Results 1 to 9 of 9
  1. #1
    Join Date
    Jul 2003
    Posts
    180

    Proftpd installation error

    After downloading the stable version of Proftpd at ftp://ftp.proftpd.org/distrib/source...-1.3.0a.tar.gz, I untar the file into /usr/src directory and then try to do the installation...but I get this:

    Code:
    [[email protected] src]# ls
    proftpd-1.3.0a
    [[email protected] src]# cd proftpd-1.3.0a
    [[email protected] proftpd-1.3.0a]# ./configure
    checking build system type... i686-pc-linux-gnu
    checking host system type... i686-pc-linux-gnu
    checking target system type... i686-pc-linux-gnu
    checking for gcc... no
    checking for cc... no
    checking for cc... no
    checking for cl... no
    configure: error: no acceptable C compiler found in $PATH
    See `config.log' for more details.
    [[email protected] proftpd-1.3.0a]#
    It's on a fresh CentOS Linux 4.3 w/ Webmin 1.310.

    Any help would be hot.

  2. #2
    Join Date
    May 2001
    Location
    HK
    Posts
    3,076

  3. #3
    Join Date
    Jul 2003
    Posts
    180
    I tried yum install gcc and then yum install gcc-c++ gcc successfully. Ran the ./configure again and Proftpd went through a one minute install. But my Proftpd doesn't seem like it is installed yet. Where to look?

  4. #4
    Join Date
    May 2001
    Location
    HK
    Posts
    3,076

    Smile

    I think you could do, yum install proftpd as well and saves your time for compiling and installing your own.

    Make sure you did make && make install after the configure otherwise it isn't installed.

    I think you can start proftpd by issuing this command:
    /usr/local/bin/proftpd

    or locate proftpd by doing: whereis proftpd if the path above is wrong
    By default it should install in /usr/local

  5. #5
    Join Date
    Jul 2003
    Posts
    180
    I did make and make install...and it went through a few seconds of installing (I can post the log if you'd like).

    I tried the "yum install proftpd" before all this, but this is what I get:

    Code:
    [[email protected] proftpd-1.3.0a]# yum install proftpd
    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Parsing package install arguments
    No Match for argument: proftpd
    Nothing to do
    [[email protected] proftpd-1.3.0a]#

  6. #6
    Join Date
    Jul 2003
    Posts
    180
    Nevermind:

    Got it to work.

    [[email protected] proftpd-1.3.0a]# whereis proftpd
    proftpd: /usr/src/proftpd-1.3.0a/proftpd.spec /usr/src/proftpd-1.3.0a/proftpd /usr/local/sbin/proftpd /usr/local/etc/proftpd.conf
    [[email protected] proftpd-1.3.0a]#
    Tada! Got the paths right and Proftpd works. Thanks for the big help! : )
    Last edited by sir_han; 12-22-2006 at 06:20 AM.

  7. #7
    Join Date
    Jul 2003
    Posts
    180
    One problem solve, another arise....

    My Proftpd cannot start. I get this error:

    Code:
    sh: /etc/init.d/proftpd: No such file or directory
    Any ideas?

  8. #8
    Join Date
    Jul 2003
    Posts
    180
    /usr/local/bin/proftpd is to start the server. What is the command to stop the server?

  9. #9
    Join Date
    May 2001
    Location
    HK
    Posts
    3,076

    Smile

    cp %PROFTPD_SRC_DIR%/contrib/dist/rpm/proftpd.init.d /etc/rc.d/init.d/proftpd
    chmod 0755 /etc/rc.d/init.d/proftpd

    service proftpd start
    service proftpd stop

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •