Results 1 to 8 of 8
  1. #1

    My site doesn't work

    I asked this in

    but the answer is too slow.

    I am using

    However, doesn't work.

    I abandoned the website for so long. Suddenly, I checked again and found out it doesn't work.

    What should I do?

  2. #2
    Join Date
    Aug 2005
    Barcelona, Spain
    You should check if the database connection info is still correct. It looks like wrong username or password to me?
    hi there!

  3. #3
    Are you sure? It used to work just fine. Also, if I logged in as administrator I got this message:
    Can't create/write to file '/tmp/#sql_9ee_0.MYI' (Errcode: 13)
    File: /home/legendar/public_html/Sources/BoardIndex.php
    Line: 82

    To logged in as administrator smf need to be able to access database. So that doesn't seem to be the problem there.

  4. #4
    I tried to logged in phpadmin and I got this message:
    Warning: session_write_close(): open(/tmp/sess_5f02aabf1c2d7a26d689a987f93b1192, O_RDWR) failed: Permission denied (13) in /usr/local/cpanel/base/3rdparty/phpMyAdmin/index.php on line 44

    Warning: session_write_close(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in /usr/local/cpanel/base/3rdparty/phpMyAdmin/index.php on line 44

  5. #5
    Join Date
    Jan 2005
    Scotland, UK
    chmod -R 777 /tmp

    Server Management -
    Infrastructure Management, Web Application Performance, mySQL DBA. System Automation.
    WordPress/Magento Performance, Apache to Nginx Conversion, Varnish Implimentation, DDoS Protection, Custom Nginx Modules
    Check our wordpress varnish plugin. Contact us for quote: [email protected]

  6. #6
    I just find out that both of my forum face that fate. Looks like this is an SMF thing. Wordpress don't give me this problem.

  7. #7
    This technique chmod -R 777 /tmp, work though.

    Thanks a lot. I wonder what happened. It used to work. Then it went wrong. I mean the permission of /tmp have never changed before things went wrong.

    Anyway, now it is fixed.

  8. #8
    Join Date
    Dec 2006
    You'll also want to confirm that the sticky bit is set on that directory. This is very important. If an ls -l does not show a t in the permissions you will need to either perform a "chmod +t /tmp" or "chmod 1777 /tmp".

    In case you're curious here is a link to explain the purpose of the sticky bit:
    Caro.Net: Support is everything
    Offering High Quality Dedicated Servers.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts