Results 1 to 6 of 6
  1. #1

    Sendmail/qmail working sporadically

    Hi there - I've just moved over to a VPS package with startlogic and am running into a problem with having mail sent from my new server. Basically, mail is backing up in the mail queue and is failing to be sent, but then after a long time (a few days) it, or at least some of it, will suddenly be sent successfully for no apparent reason.

    In the meantime the mail is backing up in the mail queue. Looking at the qmail logs I'm seeing lots of "Sorry,_I_wasn't_able_to_establish_an_SMTP_connection" type of errors, and occasional "Sorry,_I_couldn't_find_any_host_named_localhost.localdomain" errors (though the SMTP ones are far more common place).

    I've gone through the plesk/virtuozzo mail server options and they seem fine, and it does send some mail through, just very sporadically and up to about 5 days late. I've tried asking SL tech support but they are completely washing their hands of any problem

    Any help would be much appreciated!!

  2. #2
    Join Date
    Feb 2003
    That second error is a real strange one.

    Been a while since I ran qmail but I'd look into the smtproutes file that qmail uses. Look for strange entries or anything at all in the file.

    Also check any firewall rules for blocking port 25 outbound. Make sure your provider doesn't require you to relay email through their server.

  3. #3
    There is no smtproutes file at all. Firewall config should be ok as its actually sending the mail sporadically. It will sit in the queue and error out for quite a while and then will suddenly go. A lot of it has been forwarded to my personal email account so I can vouch that it is actually being sent and is arriving successfully, but not before getting stuck for quite a while (up to a week), yet some just flies through with no problem ???

  4. #4
    Join Date
    Dec 2002
    chica go go
    can you run

    cat /etc/hosts

    and send back the output? thanks.

  5. #5
    Here's what I've got - basically just the localhost definition...

    [[email protected] ~]# cat /etc/hosts localhost.localdomain localhost

  6. #6
    Ok, I finally worked out the problem. The issue was that startlogic had not set up reverse DNS lookup on the server, and that was what all of the 4.4.1 errors were from. Once I got them to do that the mail worked its way through. Don't ask me why some ISPs would accept the mail intermittently though.

    For anyone else encountering this sort of problem I would heartily recommend you try the DNS configuration testing tools at the following location

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts