Results 1 to 2 of 2
  1. #1

    Lightbulb BQ+Centos Configuration Help --

    I just installed the most recent BlueQuartz+Centos image from the Nuonce website. Most configuration gone well so far.

    However while trying to install SpamAssassin from the tarball distribution from Spamassassin, I get the following error:

    rpmbuild -bb --nodigest spamassassin.spec
    error: Failed build dependencies:
    perl(Digest SHA1) is needed by spamassassin-3.1.7-1.i386

    I installed Digest like this:

    rpm -ivh /install/Digest/perl-Digest-SHA1-2.11-1.rh7.rf.1i386.rpm

    and received 100% success. However, I still receive the same error above when repeating the rpmbuild for SpamAssassin. I am just learning the ways of the "force", so go easy on

    FYI- this installation is on a "whitebox" server to prepare for hardware repairs to my Raq4 hardware. Most of my experience is limited to the 550os.

    Thanks in advance!

  2. #2

    Solution Found

    Well, it turns out I solved this one with a little clarification.

    The two packages that I was using were based on Red Hat 7. I am not completely sure if it was the issue, but here is what I did.

    I found out that Centos is based on Red Hat Enterprise Server 4. I then went in search of an rpm of SpamAssassin already built for rhel4 and found one. I installed using rpm -ivh /directory/***packagename.rpm and got the same error. (Which was a dependancy error)

    Then I went out and found an rpm package for Digest SHA1 and a few others that were required by Digest. I installed them in order of requirement using rpm and all went well.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts