Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2006
    Location
    London, UK
    Posts
    26

    Webmin and F-Prot Problems

    I wonder if anyone can help me with this one please. I’m running version 1.29 webmin installed from the Zeffie package. It all seems to be okay apart from the where it tries to connect to an outside source such as CPAN for Perl updates. The error I get is in the Perl Modules tab:

    Select a new Perl module to compile and install on your system. Then the pop up window says “Failed to lookup IP address for www.cpan.org”

    I have checked at the time when I use the command that www.cpan.org is available via HTTP in a normal browser window and it seems to be there and running.

    I’ve also got a similar problem with updates to F-Prot. I've got a CRON job that runs the check-updates.pl file. However this always returns "Can't connect to updates.f-prot.com:80 (Bad hostname'updates.f-prot.com')"

    Again I've checked, and updates.f-prot.com is available and not down.

    Has anyone any ideas why the RAQ cannot seem to connect to external addresses?

    Just another question on the Zeffie webmin pkg. I notice that it doesn’t preinstall perl-Net-SSLeay which I think is needed to allow https access – this is when I found the connection problems with CPAN mentioned above.

    Can anyone help with adding https access to Webmin?

    Thanks

  2. #2
    Join Date
    Nov 2006
    Location
    London, UK
    Posts
    26
    Through another post I’ve found the answer to this problem. I had put an incorrect IP address in the main DNS section of the RAQ setup screen. Now that I’ve put the correct address everything is fine and F-Prot and Webmin can all connect to the web.

    The way I was advised to fine if this was the error was to try a ping to any web site via SSH, if that gave an error there it was a good indication that the DNS setting was wrong.

    With regards to getting https access and Net-SSLeay added to Webmin, I looked around at other peoples .pkg files and found that the one supplied by RaQ4-rackAID-webmin Release 1.140-1 also installs Net-SSLeay for you. So I uninstalled the Zeffie package and used the rackAID. All I did then was use the internal update routine of Webmin to bring it up to date.

    I hope these details help others who might have a similar problem.

    Thanks

  3. #3
    Join Date
    Aug 2006
    Posts
    275
    FYI for future readers: Zeffie runs a forum for supporting his (mostly Raq4 oriented) distros. It's not a general-purpose forum but might contain the best answer for those who choose to use Zeffie's packages.

  4. #4
    Join Date
    Nov 2003
    Location
    Northville, Michigan
    Posts
    325
    I will be adding Net-SSLeay to my next webmin build which I try to keep somewhat current to avoid the security holes in older versions that can allow unwanted root access...

    oh and the forum is for all the Cobalt models and makes...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •