Results 1 to 6 of 6
  1. #1

    Logrotate crashing raq daily

    Actually I'm not sure it it's the culprit, but something is.

    Every day my raq will die at 4 am. I checked the cron.daily directory, and logrotate is in there. Is there any way to check and see what runs at 4am to kill the raq every day?

    I just manually ran the logrotate, and the server died again. I watched the server usage with TOP - the CPU went up to 80is and hovered there for about 20 minutes. The mem was maxed out also (only have 256 megs).

    I think it's the logrotate that is causing the daily crashes. If it is, Id like to disable it, and set it to delete the server logs. I dont need them anymore.

    Can you guys help? *fingers crossed*

    For the longest time, it worked great. I had the latest webalizer installed. But, then it started getting *really* slow at about 4am every day - CPU usage would shoot up to 30. So i uninstalled the webalizer package using the uninstall instructions from the cobalt site (someone on this forum had already pointed out how in another thread). Uninstall looked like it worked oK, but now the raq crashes every day.

    Any suggestions?

    Thanks in advance!


  2. #2
    Join Date
    May 2001
    @ Work - Usually!
    You could go into /etc/logrotate.d/ and move the configuration files out of there. Slowly put each one back and run logrotate each time if you get unusual results with a particular log, then you have tracked down your problem.

  3. #3
    Awesome, thanks for the suggestions.

    I just tried that. I moved all the files into a backup dir somewhere else. Then, I put them in the /etc/logrotate.d/ and ran logrotate.

    One by one...

    Each time, logrotate ran in about 2 seconds. Finally, after I moved them all, it still ran in 2 seconds. This is really weird - because before when I would run it, it would crash the server without fail.

    Any ideas?
    *noobie on the loose*

  4. #4
    Join Date
    Apr 2002
    Does the RaQ crash again @ 4 AM?

    If not: Don't worry, be happy....

  5. #5
    Originally posted by FiberOptic
    Does the RaQ crash again @ 4 AM?

    If not: Don't worry, be happy....
    LOL, I don't know yet - guess I will need to wait. I have a hard time with the whole "if it's not broke, don't fix it" thing...

  6. #6
    Join Date
    Aug 2001
    New Zealand
    I had this problem on a RAQ3 seemed it was the apache one in
    logrotate and the parsereport
    I tuned on analog now the webstats in gui don't work but does not chrash touch wood I have other stats any way

    to turn off mv /usr/local/sbin/analog to

    make a new one pico /usr/local/sbin/analog
    exit 0

    chmod it 700 /usr/local/sbin/analog

    and then when logrotate runs anaolog does not use up all that


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts