Results 1 to 21 of 21
  1. #1

    mysql remote server?

    Hello,
    I have an CentOS server.
    Well...it has php, mysql ...all installed and configured.
    I want to access mysql remote....I've tryed...and it doesn't work.
    Can you tell me what settings do I have to do?
    I want the server to allow mysql remote connections from all IPs but just for an username and hist databases.
    Thank you!

  2. #2
    Join Date
    Feb 2006
    Location
    Swellyville
    Posts
    2,340
    <<< Please see Forum Guidelines for signature setup. >>>

  3. #3
    Thanks but I need an ssh guide.
    I have cpanel/whm ...but I like to do it via ssh.
    or if someone here can make me a guide how to do it via whm it's ok.
    Thanks!

  4. #4
    Bump...an admin please move this thread in technical problems.
    Thanks!

  5. #5
    Join Date
    Jun 2004
    Location
    North of some border
    Posts
    5,589
    Quote Originally Posted by phpnoobs
    ...an admin please move this thread in technical problems.
    Done.

    Lois
    Do you have a WHT question or concern? Please open a helpdesk ticket.

    "Do what you can, where you are, with what you have." Theodore Roosevelt

  6. #6
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    execute the following commands in your mysql console

    grand all priviliges on *.* to root@'%' identified by 'your_mysql_root_password';

    and

    flush privileges;


  7. #7
    Please make me an step by stem guide.
    Thanks...
    So what I want is to allow...remote mysql connection for a specific account...can I do this?
    If no...just make me an step by step guide in how to set up the posibility of accessing mysql remote.
    Thanks!

  8. #8
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    grand all priviliges on <database_name>.* to <db_user>@'%' identified by 'your_mysql_user_password';

    thats the only difference ..

    hope this helps

  9. #9
    mysql> data_base.* to username@'%' identified by 'password';
    ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'data_base.* to username@'%' identified by 'password' at line 1

  10. #10
    any advise please?because I get that error?

  11. #11
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    the command is ""grand all priviliges on <database_name>.* to <db_user>@'%' identified by 'your_mysql_user_password'; ""

  12. #12
    mysql> ""grand all priviliges on data_base.* to myuser@'%' identified by 'mypass';""
    ERROR 2006 (HY000): MySQL server has gone away
    No connection. Trying to reconnect...
    Connection id: 9660
    Current database: *** NONE ***

    ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '""grand all priviliges on data_base.* to myuser@'%' identified by 'my' at line 1


    any advise please?

    I've pasted even your reponse )

    mysql> ""grand all priviliges on <database_name>.* to <db_user>@'%' identified by 'your_mysql_user_password'; ""
    ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '""grand all priviliges on <database_name>.* to <db_user>@'%' identified by 'your' at line 1
    ->


    Any advise?

  13. #13
    Join Date
    Dec 2002
    Location
    chica go go
    Posts
    11,858
    query i use is:

    Code:
    GRANT ALL PRIVILEGES ON database.* TO [email protected] IDENTIFIED BY 'password';

  14. #14
    I've do so and get this:

    Code:
    mysql> GRANT ALL PRIVILEGES ON data_base.* TO [email protected] IDENTIFIED BY 'password';
    Query OK, 0 rows affected (0.22 sec)
    
    mysql>
    It will be ok?

  15. #15
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    yeah now execute
    flush privileges

  16. #16
    GRANT ALL PRIVILEGES ON database.* TO user@'%' IDENTIFIED BY 'password';
    I do it so and it seems it works...
    Why I need to execute flush privileges?

  17. #17
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    If you modify the grant tables manually (using INSERT, UPDATE, etc.), you should execute
    a FLUSH PRIVILEGES statement to tell the server to reload the grant tables.

    its just a routine command that comes with 'grant' and comes by default for me ...forget it if you dont want an extra command

  18. #18
    Now I can connect at MySQL server...bu I can't view the tables or something.
    Any advise please?

  19. #19
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446

  20. #20
    I hade this same problem i was looking all over cpanel forums but this topic has fixed it
    <<Please see rules for signature setup>>

  21. #21
    Join Date
    Apr 2005
    Location
    Cochin
    Posts
    2,446
    cpanel has an option to specify the access to remote host while assigning the user to the database.
    check out the Mysql management section in the cpanel and you should notice the option instantly and hence you dont have to go through these commands

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •