So I need to install PECL Mailparse for a script I want to use.

My setup:
- cPanel box
- PHP 4.4.3 running as apache module
- PHP 5.2.0 running as CGI

Since there was no zend optimiser bundled with PHP 5.2.0 from cpanel, I downloaded ZendOpt 3.2.0.
However I've installed it over my old zend so now both php4 and php5 use the same php.ini file.

pecl install mailparse, did not work. here's the result:
[email protected] [/usr/local/php5/bin]# pecl install mailparse
downloading mailparse-2.1.1.tgz ...
Starting to download mailparse-2.1.1.tgz (35,883 bytes)
..........done: 35,883 bytes
9 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
/usr/bin/phpize: /tmp/tmpjrqhUW/mailparse-2.1.1/build/shtool: /bin/sh: bad interpreter: Permission denied
Cannot find autoconf. Please check your autoconf installation and the $PHP_AUTOCONF
environment variable is set correctly and then rerun this script.

ERROR: `phpize' failed
[email protected] [/usr/local/php5/bin]#
So here are the steps I did

cd /root/mailparse
untar zvfx mailparse-2.1.1.tgz
cd mailparse-2.1.1
make install
cp /usr/local/lib/php/extensions/no-debug-non-zts-20020429/ /usr/local/php5/lib/php/extensions/
edited my php.ini file (/usr/local/php5/lib/php.ini)

extension_dir = /usr/local/php5/lib/php/extensions/

rebooted apache and...

info.php4 = shows mailparse
info.php5 = no mailparse

Why would php4 show it and not php5 when I build it specifically using php5's phpize.

Any tips greatly appreciated. Thank You.