Results 1 to 8 of 8
  1. #1
    I have a box with CPanel. Haven't had many problems recently, however now my users can't login to FTP.

    Clients connect to FTP fine, as soon as their password is entered the client replies with "Connection closed by remote host.".

    The only thing I have recently done was edit the php.ini file:

    open_basedir = .
    disable_functions = readfile,system

    I doubt that has anything to do with it.. There is no firewall on the server so that isn't the issue and all sites on the server seem to be affected, multiple users report not being able to connect. Everything else is working fine, just the FTP.

    I tried switching between PROFTPD & PureFTPD numerous times, but with no effect. Any suggestions how I can get this fixed?

    PS - Its not a passive/active FTP issue. I've also scanned all related threads & google with no helpful results..
    Last edited by sirius; 11-28-2006 at 04:44 PM.
    <<See rules for signature setup>>

  2. #2
    I've created a new account through WHM and that account I can login via FTP, the others will disconnect as soon as the correct password is entered. If the incorrect password is entered it will say so, so it recognises the correct passsword.

    I've also used the "Synchronize FTP Passwords" option but to no avail.

  3. #3
    Join Date
    Mar 2006
    does your ftp logs tell you anything? I have no idea where these would be on a cpanel server, but if you have ssh access you should be able to locate them (if it's a linux box, remember to run updatedb first, that will update the database which locate uses)... you're looking for something like pureftpd.log for pureftp, or proftpd.log if pro ftp...
    || Semi-professional PHP developer || Exams right now, don't I just feel lucky? ||

  4. #4
    I did updatedb then: locate *pure* & locate *proftp*

    Nothing came up that looked like a log file..
    <<See rules for signature setup>>

  5. #5
    Join Date
    Mar 2006
    Wierd... how about your system messages? normally located in /var/log/messages ? there must be something somewhere in some logs which show the error which causes the conn close...
    || Semi-professional PHP developer || Exams right now, don't I just feel lucky? ||

  6. #6
    Join Date
    Sep 2005
    Southern California
    Check the max connections on your FTP server, and also try FTP'ing from the shell on the server to see if it kills that too.

  7. #7
    Nov 28 11:37:27 server2 pure-ftpd: ([email protected]) [WARNING] Authentication failed for user [username]

    /var/log/messages has multiple of these instances from when I tried to login to FTP, the login/passwords were correct when trying to login.

    In SSH I FTP to the server and try to login as a user with the correct login/password, it disconnects, but I get this error message:

    421 Service not available, remote server has closed connection
    Login failed.
    No control connection for command: No such file or directory

    I can however login with the new account on the server I've created, just not the old ones...
    Last edited by optimumd; 11-28-2006 at 07:36 PM.

  8. #8
    I'm thinking it's a cpanel related issue. When doing a Cpanel Update, or in certain parts of the User Cpanel I find an error message "Can't locate in @INC".

    I did some research on correcting this problem, (installing a perl module, upgrading cpanel, ect).

    It seems the FTP is currently working although I haven't fixed the error. Thank you for your help, I will update with more info if I get it fixed.
    <<See rules for signature setup>>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts