Results 1 to 5 of 5
  1. #1

    php.ini memory_limit 100M ignored

    This is a strange problem.

    In php.ini I have the following settings:
    memory_limit 100M
    post_max_size 100M
    max_execution_time 360

    I can upload movies upto 100MB size easily with no problem.

    However, if I try to upload images (6 images around 840kb each) 4.95MB total I get the following error:

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 9088 bytes) in /home/*edited*/public_html/upload.html on line 207

    Now why is it saying the memory_limit is 8M, when php.ini and domain.com/phpinfo.php shows the memory_limit is set at 100M?

  2. #2
    Some of the programmers try to define the limits within the script, So makesure with your script.
    Live Your DreamZ
    ~Besty

  3. #3
    Join Date
    May 2006
    Location
    India
    Posts
    661
    Please make sure that you have placed this php.ini in the folders where this script is being called.
    SparkSupport.Com - The Premier Tech Company
    IT Infrastructure Management|Software Development|
    Cloud Solutions|Email |VOIP|Streaming
    Contact us for a free quote: busdev@sparksupport.com
    Phone : 1- 408-335-0493 | Skype : spark.subhish

  4. #4
    As stated above php.ini definitely has these settings:

    memory_limit 100M
    post_max_size 100M
    max_execution_time 360

    Confirmed by uploading phpinfo.php to directory and loading in browser. Also by uploading 40MB movie file way beyond the 8MB limit experienced when uploading images.

    8MB error is only occurring when uploading images which are resized by script using GD.

    This is the message from programmer:
    "hi there, well, the problem i don't think is from the php memory limit, but the memory limit of the GD image processing library of the php.
    I have heard somewhere in the past, that it has some problems with processing quite big images like the ones you try to input.
    So the problem isn't from the upload, but from the image resizing we do with the GD library. Thats why it happens only with the picture
    galleries and not with the movie ones. Try getting your host support looking into the GD library settings, I have never played with it pretty deeply
    and i don't know its exact settings."

    Does anyone know how to edit the 8MB limit in GD library settings?

  5. #5
    Problem was a bug in php 4.4.4 http://bugs.php.net/bug.php?id=34156

    I'm now using an older version of php and everything works great.

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •