Results 1 to 9 of 9
  1. #1
    Join Date
    Mar 2003
    Posts
    663

    On hell problem here~

    This is a new redhat server. By default my system already include a root and an admin account. Both password are using the same. I tried disabling direct ssh root login and wanted to use admin to login and su to root;

    It works but however now, I can login via admin and when I su to root, I got incorrect password! I haven't even change any password!

    Any ideas are greatly appreciated

  2. #2
    Join Date
    Jun 2003
    Location
    UK
    Posts
    6,601
    See if you can use sudo -s

    Also do you have a control panel on it?
    Russ Foster - Industry Curmudgeon

  3. #3
    Join Date
    Mar 2003
    Posts
    663
    When I do sudo -s I got this:

    [[email protected] ~]$ sudo -s

    We trust you have received the usual lecture from the local System
    Administrator. It usually boils down to these two things:

    #1) Respect the privacy of others.
    #2) Think before you type.

    Password:
    admin is not in the sudoers file. This incident will be reported.

    I have a Plesk control panel! Does it helps?

  4. #4
    I'm currently assuming that Plesk has some kind of file editor where you can go and edit the sshd_config file in /etc/ssh. That way you can re-edit the file and allow root log ins once again. Afterwards restart SSH.

    I can be wrong but you can always ask your DC to log into your server and change your password from there.
    ServerTweak Networks, LLC >> ServerTweak.com
    Experience the fastest network and superior servers, feel the power of ServerTweak!
    Fremont, CA DataCenter | Dedicated Servers | Colocation | Cross Connects HE.net | 1/4 - Full Cab Sales

  5. #5
    Join Date
    Mar 2003
    Posts
    663
    I feel so bad having to trouble the ev1 staff for something I've done wrong Anyway yeah, they're resetting my pwd for me.

    5:07:09 AM==============================================
    That was the correct port. I was able to easily recreate this error. I am now sending this server to our data center to have the root password reset for you.

    5:12:16 AM================================================
    We will be resetting your password shortly. Please stand by for further updates.

    Thank You
    KyleS
    EV1Servers
    Houston Datacenter 2
    Datacenter Technician
    =======================================================

    But seriously though, i don't know what the hell I've done wrong?

  6. #6
    Join Date
    Jan 2006
    Location
    Somewhere in USA
    Posts
    110
    Anlene, you should know that on a server running Plesk, admin is the master user for Plesk, and root is the master user for the server. This is how the guys from Plesk created the Control Panel, so that someone finds out your admin password, can not login to server with it. If you want to disable direct ssh root login, you will have to create another user(not admin, the user from Plesk ) and give sudo permissions to it(edit /etc/sudoers file). Also, a good idea will be to not have both users, admin and root, using the same password .

    Hope this will help you!
    https://www.vpnin.net - Reliable and secure vpn services

  7. #7
    Join Date
    Mar 2003
    Posts
    663
    oh thanks k3. So you mean I can't su - using the admin account and that is why I always encounter wrong password when I did that? So if I understand you correctly is that I need to create another user account and give it permission to wheel?

  8. #8
    Join Date
    Jan 2006
    Location
    Somewhere in USA
    Posts
    110
    Yep, that is the idea..
    https://www.vpnin.net - Reliable and secure vpn services

  9. #9
    Join Date
    Mar 2003
    Posts
    663
    Thanks man! I shall give it a try right after my firewall woes!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •