Results 1 to 2 of 2
  1. #1

    httpd no response

    i'm running CentOS 4.4 Apache 2.0.52-28
    sometimes (might be once a day or once every few days or even few times a day)
    i get no http response from the server, but the server is up and working,
    and httpd is not taking CPU.
    There nothig special in the error and access log
    restart http solve the problem.

    once restarted the problem solved until the next time.

    'top' doesn't show anything suspicious
    i'm able to connect to the server through ssh

    just httpd not responding, nothing else.

    i did netstat -tap, and it looks like the server is listening to 80,
    i got the following lines while gerping out only my IP. the lines look like that:
    tcp 0 0 mydomain:http SYN_RECV -

    so i stopped the browser, and hit ENTER again to try and load the page.
    then, i ran the netstat again, and got one more line.
    each time i stopped the browser and tried again, i got one more line like the one above.

    so i then restarted httpd, and it's all fine.

    what could it be, and what could be done to solve this problem ?

  2. #2
    Join Date
    Apr 2004
    Have you tried recompiling Apache? If your using CPanel in WHM scroll down to "Apache Update" and run through that and see how you go.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts