Results 1 to 2 of 2
  1. #1

    No module adp94xx

    hello,

    i tried upgrading kernel cleanly.. but when i ran at the end of compile

    make install

    ..........

    WARNING: No module adp94xx found for kernel 2.6.18, continuing anyway


    so the module is not there... this is the modprobe.conf :

    alias scsi_hostadapter1 adp94xx
    alias eth0 e1000
    alias eth1 e1000
    alias scsi_hostadapter2 ata_piix
    alias usb-controller ehci-hcd
    alias usb-controller1 uhci-hcd


    i tried downloading the source and compiling it of the module :

    when making :

    make -C /usr/src/linux-2.6.18 M=`pwd`
    make: Entering directory `/usr/src/linux-2.6.18'
    LD /usr/src/drivers/adp94xxx/built-in.o
    CC [M] /usr/src/drivers/adp94xxx/adp94xx_osm.o
    /usr/src/drivers/adp94xxx/adp94xx_osm.c:92: error: syntax error before string constant
    /usr/src/drivers/adp94xxx/adp94xx_osm.c:92: warning: type defaults to `int' in declaration of `MODULE_PARM'
    /usr/src/drivers/adp94xxx/adp94xx_osm.c:92: warning: function declaration isn't a prototype
    /usr/src/drivers/adp94xxx/adp94xx_osm.c:92: warning: data definition has no type or storage class
    /usr/src/drivers/adp94xxx/adp94xx_osm.c: In function `asd_flush_device_queue':
    /usr/src/drivers/adp94xxx/adp94xx_osm.c:1402: error: structure has no member named `sc_magic'
    /usr/src/drivers/adp94xxx/adp94xx_osm.c:1490: error: structure has no member named `sc_magic'
    /usr/src/drivers/adp94xxx/adp94xx_osm.c: In function `asd_destroy_device':
    /usr/src/drivers/adp94xxx/adp94xx_osm.c:2782: warning: unused variable `ch'
    /usr/src/drivers/adp94xxx/adp94xx_osm.c:2783: warning: unused variable `id'
    /usr/src/drivers/adp94xxx/adp94xx_osm.c:2784: warning: unused variable `lun'
    /usr/src/drivers/adp94xxx/adp94xx_osm.c: In function `asd_get_sas_addr_from_platform_map':
    /usr/src/drivers/adp94xxx/adp94xx_osm.c:3189: warning: comparison is always false due to limited range of data type
    make[1]: *** [/usr/src/drivers/adp94xxx/adp94xx_osm.o] Error 1
    make: *** [_module_/usr/src/drivers/adp94xxx] Error 2
    make: Leaving directory `/usr/src/linux-2.6.18'





    please anybody have a patch for this tell me.. or a clear solution

    because i got tired of adaptec and 3ware

  2. #2
    no comments !!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •