Results 1 to 4 of 4
  1. #1

    php 5.2.0 / includes

    I just upgraded to 5.2.0 on cpanel and now I get clients complaining that one cannot login to Drupal (it won't login correctly) while another said this

    Statements such as "<? include ('http://domain.net/inc/panel-right.php'); ?>" cause error

    Another person says zend optimizer is not installed. I know zend 3.0.1 is not compatible with php 5.2.0
    so what should I know? Apparently it is not picking up 3.0.2 with php 5.2.0 which I know is incompatible.

    I am downgrading back to 5.1.6 and keeping zend 3.0.2

    I have

    PHP 5.2.0
    ioncube 5.1
    zend optimizer 3.0.2
    phpsuexec enabled

    What would be the actual cause and fix?
    Last edited by Silent Noise; 11-10-2006 at 01:20 AM.

  2. #2
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    Its a new option in the php.ini you need to enable:

    allow_url_include = On
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  3. #3
    Join Date
    Dec 2002
    Location
    chica go go
    Posts
    11,858
    Quote Originally Posted by Silent Noise
    I just upgraded to 5.2.0 on cpanel and now I get clients complaining that one cannot login to Drupal (it won't login correctly) while another said this

    Statements such as "<? include ('http://domain.net/inc/panel-right.php'); ?>" cause error

    Another person says zend optimizer is not installed. I know zend 3.0.1 is not compatible with php 5.2.0
    so what should I know? Apparently it is not picking up 3.0.2 with php 5.2.0 which I know is incompatible.

    I am downgrading back to 5.1.6 and keeping zend 3.0.2

    I have

    PHP 5.2.0
    ioncube 5.1
    zend optimizer 3.0.2
    phpsuexec enabled

    What would be the actual cause and fix?
    Well, you're banned so i don't expect an answer, but why don't your clients just use file paths for includes? Using urls in includes when the file is on the local machine seems awfully dumb.

  4. #4
    Join Date
    Jan 2002
    Location
    UK
    Posts
    1,034
    3.0.2 isnt php 5.2 compatible whoever told you that is misled.
    Chris Collins
    Hostingfreak.net
    Directadmin Hosting in europe
    www.hostingfreak.net

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •