Results 1 to 2 of 2
  1. #1
    Join Date
    Aug 2002

    RBL in Exim and SMTp problem

    Hi all

    i have add RBL in Exim but now i have a problem with all the customer that use the smtp of my server, most of all use a dialup connection and all these ip are blacklisted so they can't send anymore email from my server, how can i remove the control only for outgoing email?

    in exim.conf i already have this

    # Reject message if address listed in blacklist.
    deny message = Message rejected because $sender_fullhost is blacklisted at $dnslist_domain see $dnslist_text :
    !hosts = +relay_hosts
    !authenticated = *
    dnslists = : : : : : :
    # RBL Bypass Local Domain List
    !domains = +rbl_bypass
    # RBL Whitelist incoming hosts
    !hosts = +rbl_whitelist
    #**# RBL List End

  2. #2
    Join Date
    Nov 2004
    Take a few example IPs that are getting blocked and jump onto and do an RBL check on those IPs. You'll then see which RBLs are listing those IPs - you can then remove those RBLs from the above.

    I suppose ideally the best option would be to do comprehensive RBL checking on port 25 and let them use port 26 for incoming email. If you can work out how to get that set up you should do pretty well.

    The other option would be to use SpamAssassin to check the RBLs giving the dialup hits, and just use those hits as point scores in SpamAssassin. That way they add to the likelihood of the email being classified as spam without being blocked. SpamAssassin has all this pretty much built in, you just have to choose the RBLs.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts